Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Highlighted
New Developer
New Developer
Posts: 32
Registered: ‎10-07-2009
My Device: Not Specified

Installing java for eclipse

I've managed to download and install the Blackberry web plug in for eclipse.  When I launch eclipse I get the following message:

 

'Javac 1.6.0 or above, which is required to build BlackBerry Widget application, is not found in your system.'

 

However, I have Java 6 JRE installed on my computer, in a different folder  than eclipse. Also when I visit the java.com web site it confirms that I have java 6 update 21 installed.

 

I tried to copy the contents of my "java" folder into a directory named "jre" within the eclipse folder but that did not resolve the problem.

 

How do I install java so that eclipse can find it?

 

 

New Developer
New Developer
Posts: 32
Registered: ‎10-07-2009
My Device: Not Specified

Re: Installing java for eclipse

Does the version of eclipse distributed with the Blackberry web plug-in require 32 or 64 bit java?

 

I have a 64 bit processor so I may have originally installed 64 bit java, though I am not sure.

Retired
Posts: 3,708
Registered: ‎10-16-2008
My Device: Z10
My Carrier: Rogers

Re: Installing java for eclipse

You will need to download the Java JDK not the JRE.. The java compiler is needed and it is only distributed in the JDK and not the runtime.

Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter
New Developer
New Developer
Posts: 32
Registered: ‎10-07-2009
My Device: Not Specified

Re: Installing java for eclipse

thanks.  I downlooaded JDK and seems to be working.

Visitor
Posts: 1
Registered: ‎09-23-2010
My Device: Not Specified

Re: Installing java for eclipse

I have both JRE and JDK but still the same error. Win7 64-bit (have both JDK 5 and 6).

New Member
Posts: 1
Registered: ‎07-12-2011
My Device: 9850
My Carrier: Vodafone

Re: Installing java for eclipse

Hello,

 

I'm also facing same issue.I have Windows 7 (64 bit) and installed Oracle JDK 1.6.0.22 (64 bit) and BlackBerry_Web_Tools_2.5.1.201010291444-2 but when I try to launch it it says "Javac 1.6.0 or above, which is required to build BlackBerry WebWorks application, is not found in your system.".

 

Please help. Thank you.

 

Kind Regards,

Amit

Retired
Posts: 3,708
Registered: ‎10-16-2008
My Device: Z10
My Carrier: Rogers

Re: Installing java for eclipse

You'll need to ensure you have the 32-bit version of the JDK installed on your machine.  It's posted as one of the system requirements but is usually a common oversight.

Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter