Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
New Developer
Posts: 10
Registered: ‎11-08-2009
My Device: Not Specified

LinkButton and png image problem

Hello,

 

When I am using  a LinkButton, it is working well in Normal browser. But it is not working in BlackBerry browser. Some, Javascript error is coming.

 

Even images of format png are not coming in BlackBerry browser, while they are working fine in Normal browser.

 

Thanks & Regards,

Gnanadeep

Retired
Posts: 3,708
Registered: ‎10-16-2008
My Device: Z10
My Carrier: Rogers

Re: LinkButton and png image problem

Can you list the four digit version of the BlackBerry operating system you are seeing this issue on?

 

As well can you post the JavaScript that is causing the error?

 

This should help us diagnose the issue

 

Cheers,

Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter
New Developer
Posts: 10
Registered: ‎11-08-2009
My Device: Not Specified

Re: LinkButton and png image problem

Thanks for the reply...

 

I am using BlackBerry 8310 Simulator..

The error is coming only when I am using the link button in master pageof my asp website.

error  -- Javascript code error

 

Thanks & Regards,

Gnanadeep

New Developer
Posts: 10
Registered: ‎11-08-2009
My Device: Not Specified

Re: LinkButton and png image problem

Please check this screenshot

 

http://i36.tinypic.com/2qvfjno.jpg

New Developer
Posts: 10
Registered: ‎11-08-2009
My Device: Not Specified

Re: LinkButton and png image problem

And now I found that the LinkButton is not working even in ListView.. If I keep ImageButton instead of LinkButton, it is working fine.. Problem is with LinkButton only. In normal browser both of them are working fine...

 

Please reply ASAP...

 

Thanks & Regards,

Gnanadeep

New Developer
Posts: 10
Registered: ‎11-08-2009
My Device: Not Specified

Re: LinkButton and png image problem

Hello please reply!!

Retired
Posts: 3,708
Registered: ‎10-16-2008
My Device: Z10
My Carrier: Rogers

Re: LinkButton and png image problem

There seems to be JavaScript that is being used that is not supported by that browser.  That device uses the 4.5 Browser which has limited DHTML functionality.  If your JavaScript is manipulating the DOM of the page it may be causing a problem.

 

You will have to debug your page by putting in alert boxes in your JavaScript to see which JavaScript call is failing.

Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter
Highlighted
New Developer
Posts: 10
Registered: ‎11-08-2009
My Device: Not Specified

Re: LinkButton and png image problem

[ Edited ]

Thanks for the Reply.

 

This is just a LinkButton....

 

New Developer
Posts: 10
Registered: ‎11-08-2009
My Device: Not Specified

Re: LinkButton and png image problem

[ Edited ]

Thanks for the reply..

 

Ok Then....Do you want me to install the latest version of visual studio plugin ?

I hope atleastthis will support Javascirpt to full extent

 

Gnanadeep

Retired
Posts: 3,708
Registered: ‎10-16-2008
My Device: Z10
My Carrier: Rogers

Re: LinkButton and png image problem

If you install the Visual Studio plug-in you will be able to trace through the code to see where it is failing.  You must use a simulator that is 4.6.0 or above (Tour is not yet supported though)

 

An ASP.NET link button can get complicated.  ASP.NET generates JavaScript and HTML on the fly depending on the browser that hits the website.  So it is possible that it will generate different JavaScript for IE/Firefox than the BlackBerry.  

 

Tracing through the JavaScript will show you the method call that is failing in the BlackBerry browser.

Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter