Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Highlighted
New Developer
Posts: 2
Registered: ‎01-27-2009
My Device: Not Specified

Mailto links give error dialog in browser when email address is missing

apologies for the duplicate post...  I posted this in the 'Bold' forum first but then realized that this is a more appropriate place for it...

 

 

Our QA guys identified this 'bug' in the Bold's web browser  (he was using the "Internet Browser" on a BB Bold):

 

When using Blackberry Bold, clicking 'email a friend' link  within the web app will get this error message dialog:

The protocol specified is not supported by the handheld. Please try a different URL. [OK]

 

Testing shows that the browser is requiring the '@' within the mailto URL,  and will give the above error message if the '@' character is missing  (of course, our app is not giving an email address in its mailto link). 

 

so,  this fails:   

 

<a href="mailto:?subject=testing123">...</a>

 

 

but this works ok (aside from populating the "to" field with "@")

 

<a href="mailto:@?subject=testing123">...</a>

 

 

As far as I know, the mailto protocol does not require an email address be provided.  i think the browser should be launching the default mail client with a blank "to:" field in the first example   (this is whats happening on other BB models).

 

Is this a known bug?  perhaps fixed in an upcoming OS revision?

 

 

thanks,

Anthony

Developer
Posts: 107
Registered: ‎09-25-2008
My Device: Not Specified

Re: Mailto links give error dialog in browser when email address is missing

You're right, this does appear to be a bug in the browser. I don't know if it has been fixed in a newer version.
BlackBerry Development Advisor
Posts: 15,727
Registered: ‎07-09-2008
My Device: BlackBerry PRIV
My Carrier: Bell

Re: Mailto links give error dialog in browser when email address is missing

I was able to reproduce this behaviour and have sent this issue to our development team.  Thanks for reporting it!
Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
New Member
Posts: 1
Registered: ‎06-02-2011
My Device: Torch
My Carrier: Rogers

Re: Mailto links give error dialog in browser when email address is missing

2 years later, this still seems to be an issue. This is causing a lot of headaches with social media sharing (one of which the option is to email to an undefined address).

 

This also happens on all new devices, not just the Bold. Have replicated on Torch as well.

 

Any idea when this will get fixed? This work around is not ideal.