Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Highlighted
Contributor
Posts: 30
Registered: ‎05-20-2010
My Device: 8900 Curve
My Carrier: Movistar
Accepted Solution

No Iframe Support Blackberry Torch 9800

Hi this example only shows a white page when you press a test link inside a iframe.

 

test.html:

<head>
<meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1">
 </head>
<body >TEST
<iframe  src="t1.html" width="250" height="250" >
</iframe>
</body>

t1.html:
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
<html>
<a href="t2.html" > Test Link </a>
</html>

t2.html:
<html>
<body>
<font color=red >Hello World</font>
</body>
</html>

Tested on Windows XP 32 bit and BlackBerry Smartphone Simulators 6.0.0\6.0.0.141 (9800) 

In config.xml it´s checked the local (show pages local).

 

This works just fine in the 9550 simulator with eclipse.

 

Contributor
Posts: 30
Registered: ‎05-20-2010
My Device: 8900 Curve
My Carrier: Movistar

Re: No Iframe Support Blackberry Torch 9800

I am using Blackberry Widgets with Eclipse for Windows XP 32 bits

Contributor
Posts: 30
Registered: ‎05-20-2010
My Device: 8900 Curve
My Carrier: Movistar

Re: No Iframe Support Blackberry Torch 9800

It´s look no one from blackberry answer or read this forums. I put like 6 diferent issues and until today i have no answer.

For me this tool is not helping at all, i wonder why they put it as a second choice for developers with questions.

And this particular issue is  something very basic (an iframe )  and it´s just wrong in OS 6.

 

 

Contributor
Posts: 11
Registered: ‎07-13-2010
My Device: 9000 Bold
My Carrier: Airtel

Re: No Iframe Support Blackberry Torch 9800

looks like u've been writing to urself. Wish i knew the answer. Did u figure it out?

Retired
Posts: 3,708
Registered: ‎10-16-2008
My Device: Z10
My Carrier: Rogers

Re: No Iframe Support Blackberry Torch 9800

Is the link you are selecting in the iframe pointing to local or remote resources?  If it is remote, have you white listed the domain/origin in which you are navigating to?

Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter
Contributor
Posts: 30
Registered: ‎05-20-2010
My Device: 8900 Curve
My Carrier: Movistar

Re: No Iframe Support Blackberry Torch 9800

[ Edited ]

Thanks for the answer.

 

It´s  a local link.

 

I know if it´s remote I have to put it white listed.

 

I tried it locally  and remote white listed of course in the config.xml with simple examples.

 

This example it´s very basic if you try it your self you will see a black screen just following the link inside the iframe I believe something it´s very wrong with the iframe support in  widgets for the OS 6.

 

I have tried everything and nothing seen to be working.

 

Please in the past you people ask some details and never answer the issue please don´t do it again.

 

And thanks for the  others developers like ArjunDhar  I believe with your comments RIM it´s finally at least reading this.

 

Retired
Posts: 3,708
Registered: ‎10-16-2008
My Device: Z10
My Carrier: Rogers

Re: No Iframe Support Blackberry Torch 9800

Have you tried it with any of the other BlackBerry 9800 simulator builds.. i.e. 6.0.0.x.  If it is a bug in that build of the OS there really isn't much I can do about it for you.  Your only route would be to upgrade the device to a newer build that doesn't have the issue.

 

Does the problem also show itself if you load the page into the Browser application instead of in a WebWorks application?

 

Sometimes there simply isn't a solution if it's a bug in the OS.

 

Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter
Contributor
Posts: 30
Registered: ‎05-20-2010
My Device: 8900 Curve
My Carrier: Movistar

Re: No Iframe Support Blackberry Torch 9800

 

Thanks for your reply.
I also try it on a real device with os 6 .
The device was 9650 
With: 
 BlackBerry Handheld Software v6.0.0.1659 (Multilangauge)
 Package Version: 6.0.0.1659
 Applications: 6.0.0.415 
 Software Platform: 4.4.0.314

 And I got the same result.

 

Retired
Posts: 3,708
Registered: ‎10-16-2008
My Device: Z10
My Carrier: Rogers

Re: No Iframe Support Blackberry Torch 9800

Is there any difference if this is running in the actual BlackBerry Browser vs a WebWorks application?

 

What I'm trying to figure out is if it is a Browser issue or possibly the way pages are being served up within a WebWorks application

Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter
Contributor
Posts: 30
Registered: ‎05-20-2010
My Device: 8900 Curve
My Carrier: Movistar

Re: No Iframe Support Blackberry Torch 9800

In the Blackberry browser it works.

 

But yes we need it in the widgets because we are using it on a OS 5 widget application on real life.

It's a SFA application. And we are migrating it to OS 6 and we can't do it without it.

The iframe let us run programs in background.