Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development


Thank you for visiting the BlackBerry Support Community Forums.

BlackBerry will be closing the BlackBerry Support Community Forums Device Forums on April 1st (Developers, see below)

BlackBerry remains committed to providing excellent customer support to our customers. We are delighted to direct you to the CrackBerry Forums, a well-established and thorough support channel, for continued BlackBerry support. Please visit http://forums.crackberry.com or http://crackberry.com/ask. You can also continue to visit BlackBerry Support or the BlackBerry Knowledge Base for official support options available for your BlackBerry Smartphone.

"When we launched CrackBerry.com 10 years ago, we set out to make it a fun and useful destination where BlackBerry Smartphone owners could share their excitement and learn to unleash the full potential of their BlackBerry. A decade later, the CrackBerry community is as active and passionate as ever and I know our knowledgeable members and volunteers will be excited to welcome and assist more BlackBerry owners with their questions."

- Kevin Michaluk, Founder, CrackBerry.com

Developers, for more information about the BlackBerry Developer Community please review Join the Conversation on the BlackBerry Developer Community Forums found on Inside BlackBerry.


Reply
New Contributor
Posts: 4
Registered: ‎03-09-2011
My Device: Not Specified

Phonegap with Blackberry

How do i develop Blackberry application using Phonegap?

 

According to Phonegap documentation, we need Blackberry Widget SDK. And to download that this link is mentioned on their website.

http://na.blackberry.com/eng/developers/browserdev/widgetsdk.jsp

 

However, there is no WIDGET SDK on this link.

 

So my question is how do I setup my computer so that I can start developing blackberry apps using PhoneGap.

 

PhoneGap link for reference

http://wiki.phonegap.com/w/page/31930982/Getting-Started-with-PhoneGap-BlackBerry-WebWorks#RunthePho...

 

Thanks

Manas

Developer
Posts: 237
Registered: ‎07-20-2010
My Device: Not Specified

Re: Phonegap with Blackberry

http://phonegap.com/start#blackberry try that out.

 

the widgets sdk has just been renamed, use the webworks sdk.

Retired
Posts: 3,708
Registered: ‎10-16-2008
My Device: Z10
My Carrier: Rogers

Re: Phonegap with Blackberry

Here is the SDK that you seek

 

https://bdsc.webapps.blackberry.com/html5/download/sdk

Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter
Retired
Posts: 3,708
Registered: ‎10-16-2008
My Device: Z10
My Carrier: Rogers

Re: Phonegap with Blackberry

[ Edited ]

I just talked to Fil at Nitobi and he has already updated the PhoneGap website with the correct link Smiley Happy

Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter
New Contributor
Posts: 4
Registered: ‎03-09-2011
My Device: Not Specified

Re: Phonegap with Blackberry

Thanks Neil.

I have already downloaded webworks.

 

I'm facing issue here.

http://phonegap.com/start#blackberry

Section 3, Point 2.

 

I'm getting this error when I try to use ant create on cmd.

"BUILD FAILED
Target "create" does not exist in the project "Build and Deploy a PhoneGap Black
Berry WebWorks Project"."

 

 

Retired
Posts: 3,708
Registered: ‎10-16-2008
My Device: Z10
My Carrier: Rogers

Re: Phonegap with Blackberry

Sorry.. I'm not much help there.  Have you posted on the PhoneGap forums?

Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter