Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
New Developer
Posts: 64
Registered: ‎01-14-2011
My Device: Priv, 9810, PlayBook, 9000, 8820
My Carrier: AT&T

[Playbook WebWorks] blackberry.app.version is always "1.0.0"

Maybe this is just me, but...

 

In my WebWorks for PlayBook application's config.xml file:

 

  • my <widget> element's "version" attribute value is "1.0.1".
  • the <feature id="blackberry.app" required="true" version="1.0.0" /> element is present.

 

 

When deploying the application to the v0.9.4 simulator, the "actual_version" is correctly reported as "1.0.1.0".

 

In my application, running in the v0.9.4 simulator, all calls to the blackberry.app.version API property return "1.0.0" -- not "1.0.1".

 

Why?  Is it just me?

 

I've tried placing all sorts of other values in the version attribute, but the API always returns "1.0.0".

 

I've also tried varying various other values in the config.xml -- id, name, author, copyright, email -- and the variations all show up correctly in the corresponding blackberry.app API property.  Except for version.

 

Am I doing something wrong?

 

Thanks.

Highlighted
Contributor
Posts: 18
Registered: ‎02-28-2011
My Device: PlayBook, Z10
My Carrier: Bell

Re: [Playbook WebWorks] blackberry.app.version is always "1.0.0"

I came across this as well. I filed a ticket against it a few days ago:

 

https://www.blackberry.com/jira/browse/TABLET-131

 

No updates yet.

 

Wayne

 

Fisherlea Systems
www.fisherlea.com