Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Contributor
Posts: 11
Registered: ‎09-05-2013
My Device: Z10
My Carrier: QTEL

Please help!!!! Oh Snap! Build request failed with message: [ERROR] Please enter a valid application version

I am trying to publish an HTML app, but when ever I click publish it gives me " [ERROR] Please enter a valid application version" and heres the config.xml if it helps. Thanks in advanceddd

 

<?xml version="1.0"encoding="utf-8"?>

<widget xmlns="http://www.w3.org/ns/widgets"

        xmlns:rim="http://www.blackberry.com/ns/widgets"

        version="1.0.0.1"id="sampleapp">

 

  <author href="http://www.srrticker.com/"

          rim:copyright="Copyright 2012-13 SRR">My Corp</author>

 

  <name>SRR Ticker</name>

 

  <description>

    Your very own FootBall Ticker

  </description>

 

  <rim:smileytongue:ermissions>

    <rim:smileytongue:ermit>access_shared</rim:smileytongue:ermit>

    <rim:smileytongue:ermit>access_location_services</rim:smileytongue:ermit>

    <rim:smileytongue:ermit>use_camera</rim:smileytongue:ermit>  

  </rim:smileytongue:ermissions>

 

  <icon src="icons/icon-150.png"/>

 

  <rim:splash src="splash-1280x768.png"/>

  <rim:splash src="splash-768x1280.png"/>

 

  <content src="index.html"/>

 

  <feature id="blackberry.ui.dialog"/>

   

  <feature id="blackberry.app">

    <param name="orientation"value="portrait"/>

    <param name="backgroundColor"value="0xFFFF0000"/>

  </feature>

 

  <access uri="http://www.somedomain.com"subdomains="true">

    <feature id="blackberry.app"required="true"version="1.0.0"/>

    <feature id="blackberry.invoke"required="true"version="1.0.0"/>

  </access>

 

  <license href="http://www.srrticker.com/"/>

 

 bbwp <C:\Users\bbcsp\Ripple Sites\SRR Ticker> -g <need4speed> -buildId <1.0.0.1> -o <C:\Users\bbcsp\Desktop>

 

</widget>

Developer
Posts: 1,280
Registered: ‎03-03-2011
My Device: Playbook, Z10, Q10, Z30 with Files & Folders and Orbit of course
My Carrier: Vodafone

Re: Please help!!!! Oh Snap! Build request failed with message: [ERROR] Please enter a valid application version


shanthanu wrote:

<?xml version="1.0"encoding="utf-8"?>

<widget xmlns="http://www.w3.org/ns/widgets"

        xmlns:rim="http://www.blackberry.com/ns/widgets"

        version="1.0.0.1"id="sampleapp">

 


There is a space missing before "id".

Files & Folders, the unified file & cloud manager for PlayBook and BB10 with SkyDrive, SugarSync, Box, Dropbox, Google Drive, Google Docs. Free 3-day trial! - Jon Webb - Innovatology - Utrecht, Netherlands
Contributor
Posts: 11
Registered: ‎09-05-2013
My Device: Z10
My Carrier: QTEL

Re: Please help!!!! Oh Snap! Build request failed with message: [ERROR] Please enter a valid application version

I fixed that mate, and I'm still getting the same error..

Retired
Posts: 1,382
Registered: ‎07-02-2009
My Device: BlackBerry Bold 9900
My Carrier: Bell

Re: Please help!!!! Oh Snap! Build request failed with message: [ERROR] Please enter a valid application version

Do you have any special character encoding in that file? The interpreter may not recognize the contents properly if a text editor has added non UTF-8 characters to it.

 

Documentation for <widget> element and version property:

https://developer.blackberry.com/html5/documentation/widget_element_834671_11.html

Follow me on Twitter: @n_adam_stanley
-------------------------------------------------------------------------------------------------------------------------
Your app doesn't work? Use BlackBerry remote web inspector to find out why.
Contributor
Posts: 11
Registered: ‎09-05-2013
My Device: Z10
My Carrier: QTEL

Re: Please help!!!! Oh Snap! Build request failed with message: [ERROR] Please enter a valid application version

[ Edited ]

I tried this mate and then I made everything plain text, now I get a new error code "An error has occured parasing the confix.xml. Please ensure that it is syntactically corect. 

 

<widget xmlns="http://www.w3.org/ns/widgets"

        xmlns:rim="http://www.blackberry.com/ns/widgets"

        version="1.0.0.0"

        id="SRRTicker"

        rim:header="RIM-Widget:rim/widget"

        rim:userAgent="BlackBerry10/MyWebWorksApp">

</widget>

Highlighted
Retired
Posts: 856
Registered: ‎07-15-2008
My Device: Passport
My Carrier: Bell

Re: Please help!!!! Oh Snap! Build request failed with message: [ERROR] Please enter a valid application version

I believe there is a bug in the packager that stops it from accepting user agent strings with a / character. Try with a plaintext one and see if it gets past that.

 

Also, the recommendation is to use a 3 part version code, and pass in the buildId on the command line. Otherwise you may have to set a 4th value that is at least 1.

Tim Windsor
Open Source Technical Lead