Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
WS1
Contributor
Posts: 10
Registered: ‎08-28-2012
My Device: Bold 9700
My Carrier: Verizon

Re: Problem Starting Build and Deploy Services in Ripple Emulator to Package and Sign an Application

Thanks for all the replies. I got it to work by uninstalling all of the Ripple, all SDKs, Chrome and I deleted the RippleSites folder related files and restarting my computer. I had to turn off Norton's Antivirus and firewall because it was stopping npRippleBD.dll when installing Ripple Emulator extension because Norton blocked it from installing.

 

Then I reinstalled Chrome, Ripple and then BlackBerry WebWorks SDK 2.3.1.5 and everything worked!

Developer
Posts: 322
Registered: ‎08-06-2012
My Device: Dev Alpha / Playbook / Curve 9300

Re: Problem Starting Build and Deploy Services in Ripple Emulator to Package and Sign an Application

Good stuff!

 

Happy developing.

If it helped you, click like. Smiley Happy
New Contributor
Posts: 6
Registered: ‎05-03-2013
My Device: Blackberry z10
My Carrier: Airtel

Re: Problem Starting Build and Deploy Services in Ripple Emulator to Package and Sign an Application

Hey there, i have one issue-

After starting the services in ripple 0.9.16, services were start and Ripple sites folder has been created.

So do i need to copy my application contents to this folder to access from localhost:9910/Application_Name.

Please help on this as i am currently failed to make build using apache server installed with port 8080.

New Contributor
Posts: 6
Registered: ‎05-03-2013
My Device: Blackberry z10
My Carrier: Airtel

Re: Problem Starting Build and Deploy Services in Ripple Emulator to Package and Sign an Application

Hi,
i am able to start the services through ripple and RippleSites folder has been created inside Users.
So, d0 i need to paste my application files inside RippleSites folder?
I Found RippleSites folder Readonly and i wont be able to change its permissions.
Please help me regarding the same.
Highlighted
WS1
Contributor
Posts: 10
Registered: ‎08-28-2012
My Device: Bold 9700
My Carrier: Verizon

Re: Problem Starting Build and Deploy Services in Ripple Emulator to Package and Sign an Application

Yes, you have to create the project folders inside ripplesites folder. Include the project folder name in the url when surfing to the site using localhost:9910/project_name
New Contributor
Posts: 6
Registered: ‎05-03-2013
My Device: Blackberry z10
My Carrier: Airtel

Re: Problem Starting Build and Deploy Services in Ripple Emulator to Package and Sign an Application

Hi there, I am following all the steps and able to start the services but when i click on about button of ripple, it shows build and deploy error.

Also when i am trying to builld an application it shows -  

Oh Snap! Build request failded with message: error 

Please Help!!!!!!!!!!

Retired
Posts: 1,561
Registered: ‎04-12-2010
My Device: BlackBerry Z10
My Carrier: Bell

Re: Problem Starting Build and Deploy Services in Ripple Emulator to Package and Sign an Application

Can you please check Option #1 in the following KB article?

http://supportforums.blackberry.com/t5/Web-and-WebWorks-Development/Solution-Ripple-Launch-is-Interr...

 

Specifically, can you confirm that you have:

1) Permitted the Ripple extension to access your filesystem; and

2) Added the --allow-file-access-from-files parameter to your Chrome shortcut.

 

For (2), I would recommend creating a new shortcut on your desktop for Chrome.exe. The reason here is that the shortcut on the Windows toolbar doesn't behave exactly like a shortcut always, and sometimes will ignore the parameter.

 

Once you've completed (1) and (2), can you also please confirm that your Ripple Version is 0.9.16? Specifically, you need to download Ripple from the BlackBerry microsite here:

https://developer.blackberry.com/html5/download/

 

Not from the Chrome store.


Erik Oros | @WaterlooErik | eoros@blackberry.com | Developer Issue Tracker

If a reply has answered your question, please click Accept as Solution to help other visitors in the future.
New Contributor
Posts: 6
Registered: ‎05-03-2013
My Device: Blackberry z10
My Carrier: Airtel

Re: Problem Starting Build and Deploy Services in Ripple Emulator to Package and Sign an Application

Hi there,
I have followed all the steps but no luck.
Still the build and deploy error is shown.
can you specify any firewall related settings causing this issue like port block?
in this case can you tell me the domain name or file name to allow through firewall?
My firewall settings were managed by my network administrators.
Also where to give --allow-file-access-from-files permission to chrome?
the link mentions that you need to give at the very end of target.
is this correct?
"C:\Program Files\Google\Chrome\Application\chrome.exe" --allow-file-access-from-files

Please Help.......

Retired
Posts: 1,561
Registered: ‎04-12-2010
My Device: BlackBerry Z10
My Carrier: Bell

Re: Problem Starting Build and Deploy Services in Ripple Emulator to Package and Sign an Application

That correct with the --allow-file-access-from-files parameter.

 

Can you post a screenshot of the error you're seeing? Also, can you please confirm which version of Ripple is installed? (Under your Chrome Extensions.)


Erik Oros | @WaterlooErik | eoros@blackberry.com | Developer Issue Tracker

If a reply has answered your question, please click Accept as Solution to help other visitors in the future.
WS1
Contributor
Posts: 10
Registered: ‎08-28-2012
My Device: Bold 9700
My Carrier: Verizon

Re: Problem Starting Build and Deploy Services in Ripple Emulator to Package and Sign an Application

If you continue to have problems getting Ripple to work I suggest you uninstall everything pertaining to the Ripple setup reboot your computer disable your antivirus and firewall then install Ripple again.