Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
New Contributor
Posts: 6
Registered: ‎05-03-2013
My Device: Blackberry z10
My Carrier: Airtel

Re: Problem Starting Build and Deploy Services in Ripple Emulator to Package and Sign an Application

hey happy to say that problem has been resolved now Smiley Happy

problems are with my firewall setting set up by our network administrator which prevents ripple from starting the services.

thank you all for your support.

really lookng forward for BB 10 development Smiley Happy

Retired
Posts: 1,561
Registered: ‎04-12-2010
My Device: BlackBerry Z10
My Carrier: Bell

Re: Problem Starting Build and Deploy Services in Ripple Emulator to Package and Sign an Application

Glad to hear it!

 

Any chance you could share some general instructions on what the network admin did to resolve it? Incase this happens for someone else.


Erik Oros | @WaterlooErik | eoros@blackberry.com | Developer Issue Tracker

If a reply has answered your question, please click Accept as Solution to help other visitors in the future.
New Contributor
Posts: 6
Registered: ‎05-03-2013
My Device: Blackberry z10
My Carrier: Airtel

Re: Problem Starting Build and Deploy Services in Ripple Emulator to Package and Sign an Application

just have one suggestion, whenever such type of error occurs try to disconnect your internet and check.
If its working then its definitely a firewall issue.
New Contributor
Posts: 3
Registered: ‎09-03-2013
My Device: none
My Carrier: none

Re: Problem Starting Build and Deploy Services in Ripple Emulator to Package and Sign an Application

Chrome no longer permits installing extensions from outside Chrome Store

Trusted Contributor
Posts: 139
Registered: ‎08-22-2013
My Device: None
My Carrier: Aircel

Re: Problem Starting Build and Deploy Services in Ripple Emulator to Package and Sign an Application

Yes you can install directly from chrome store ok buddy!

New Contributor
Posts: 3
Registered: ‎09-03-2013
My Device: none
My Carrier: none

Re: Problem Starting Build and Deploy Services in Ripple Emulator to Package and Sign an Application

@Sankar_S: I know that. But Oros, a BlackBerry Development Advisor wrote this:

"05-09-2013 12:31 AM

Can you please check Option #1 in the following KB article?

http://supportforums.blackberry.com/t5/Web-and-WebWorks-Development/Solution-Ripple-Launch-is-Interr...

 

Specifically, can you confirm that you have:

1) Permitted the Ripple extension to access your filesystem; and

2) Added the --allow-file-access-from-files parameter to your Chrome shortcut.

 

For (2), I would recommend creating a new shortcut on your desktop for Chrome.exe. The reason here is that the shortcut on the Windows toolbar doesn't behave exactly like a shortcut always, and sometimes will ignore the parameter.

 

Once you've completed (1) and (2), can you also please confirm that your Ripple Version is 0.9.16? Specifically, you need to download Ripple from the BlackBerry microsite here:

https://developer.blackberry.com/html5/download/

 

Not from the Chrome store."


He advised to download Ripple Version 0.9.16 from the BlackBerry developer website. I did the same thing but couldn't install that extension in Chrome because Chrome doesn't permit that anymore.

So I downloaded the extension from Chrome Store against Oros' advice "Not from the Chrome store" and things still don't work.

Highlighted
New Contributor
Posts: 3
Registered: ‎09-03-2013
My Device: none
My Carrier: none

Re: Problem Starting Build and Deploy Services in Ripple Emulator to Package and Sign an Application

[ Edited ]

Sorry guys, I forgot to enable 'Developer Mode' in Google Chrome extensions manager. This is my first BB10 Sencha Touch app.

But I finally got the .bar and tested it on a real device. Looks great!