Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development


Thank you for visiting the BlackBerry Support Community Forums.

BlackBerry will be closing the BlackBerry Support Community Forums Device Forums on April 1st (Developers, see below)

BlackBerry remains committed to providing excellent customer support to our customers. We are delighted to direct you to the CrackBerry Forums, a well-established and thorough support channel, for continued BlackBerry support. Please visit http://forums.crackberry.com or http://crackberry.com/ask. You can also continue to visit BlackBerry Support or the BlackBerry Knowledge Base for official support options available for your BlackBerry Smartphone.

"When we launched CrackBerry.com 10 years ago, we set out to make it a fun and useful destination where BlackBerry Smartphone owners could share their excitement and learn to unleash the full potential of their BlackBerry. A decade later, the CrackBerry community is as active and passionate as ever and I know our knowledgeable members and volunteers will be excited to welcome and assist more BlackBerry owners with their questions."

- Kevin Michaluk, Founder, CrackBerry.com

Developers, for more information about the BlackBerry Developer Community please review Join the Conversation on the BlackBerry Developer Community Forums found on Inside BlackBerry.


Reply
New Developer
Posts: 6
Registered: ‎04-27-2014
My Device: Blackberry Z10-STL100-3
My Carrier: Telus
Accepted Solution

Problem installing SDK in a new installation of Momentics

Hello all,

I am brand new to this so please forgive me if this has been answered before,  I searched but could not find anything similar.

Mt problem is this.  I installed the latest version of Momentics without problems.  Then I put my Z10-STL-3 into development mode and plugged it into my computer.  I then started up Momentics and let it run through the setup and started to download the SDK.  About half way through the download it fails with this message.

 

There was an error updating SDK. Press the Details button to review the error.
SDK Install or Update Operation operation failed: An error occurred while installing the items
An error occurred while installing the items
session context wasSmiley Sadprofile=DefaultProfile, phase=org.eclipse.equinox.internal.p2.engine.phases.Install, operand=null --> [R]

bbndk.win32.indexes.10.2.0.1155 1.0.0, action=com.qnx.tools.ide.sdk.manager.core.actions.SdkManagerInstallAction).
error in opening zip file
error in opening zip file
An error occurred while installing the items
session context wasSmiley Sadprofile=DefaultProfile, phase=org.eclipse.equinox.internal.p2.engine.phases.Install, operand=null --> [R]

bbndk.win32.indexes.10.2.0.1155 1.0.0, action=com.qnx.tools.ide.sdk.manager.core.actions.SdkManagerInstallAction).
error in opening zip file
error in opening zip file

 

Hope this makes more sense to some one than it does to me.

Thanks in advance.

Dan Gordon

 

Best regards,
Dan Gordon
Developer
Posts: 139
Registered: ‎11-04-2012
My Device: BBTEN
My Carrier: ooredoo

Re: Problem installing SDK in a new installation of Momentics

Check Your internet connection or check your proxy.

Ades Ganteng
New Developer
Posts: 6
Registered: ‎04-27-2014
My Device: Blackberry Z10-STL100-3
My Carrier: Telus

Re: Problem installing SDK in a new installation of Momentics

The file downloads just fine,  as the error message states there is a issue opening the file.  I have winzip installed.

Best regards,
Dan Gordon
Developer
Posts: 139
Registered: ‎11-04-2012
My Device: BBTEN
My Carrier: ooredoo

Re: Problem installing SDK in a new installation of Momentics

have you checked your Zip program. go to tools, then select Options, and select the types of files that are in use in compression. see picture for more details

zip.GIF

Ades Ganteng
New Developer
Posts: 6
Registered: ‎04-27-2014
My Device: Blackberry Z10-STL100-3
My Carrier: Telus

Re: Problem installing SDK in a new installation of Momentics

[ Edited ]

Winzip is set to open all assotiated file types.

Best regards,
Dan Gordon
New Developer
Posts: 6
Registered: ‎04-27-2014
My Device: Blackberry Z10-STL100-3
My Carrier: Telus

Re: Problem installing SDK in a new installation of Momentics

Is there a link somewhere where I can download the SDK and manually install it ?

Im going to search myself later but if anyone knows I would greatly appreciate it.

Best regards,
Dan Gordon
Developer
Posts: 139
Registered: ‎11-04-2012
My Device: BBTEN
My Carrier: ooredoo

Re: Problem installing SDK in a new installation of Momentics

Check Out in  Here for downloading Momentics

Ades Ganteng
New Developer
Posts: 6
Registered: ‎04-27-2014
My Device: Blackberry Z10-STL100-3
My Carrier: Telus

Re: Problem installing SDK in a new installation of Momentics

"Sigh"  Its no wonder a lot of developers are shying away from Blackberry.

Is there anyone else here that might be able to help me ?

Best regards,
Dan Gordon
Developer
Posts: 6,152
Registered: ‎07-05-2012
My Device: Playbook, Dev Alpha C, Z10 LE, Z30
My Carrier: Orange

Re: Problem installing SDK in a new installation of Momentics

@MisterMom Please ignore adesdev he seems to be posting just for the sake of posting while at the same time being incapable of understanding the OP.

 

This is a well known problem and can usually be solved by clearing your download cache or reinstalling Momentics...

 

JI: 526021

If you get the message 'error in opening zip file' while updating or downloading the Momentics IDE or API Levels, you may need to clear your download cache.
Workaround: Remove <full_path_to_IDE_install>/p2/org.eclipse.equinox.p2.core/cache/*


If you've been helped click on Like Button, if you've been saved buy the app. Smiley Happy

Developer of stokLocker, Sympatico and Super Sentences.
Highlighted
New Developer
Posts: 6
Registered: ‎04-27-2014
My Device: Blackberry Z10-STL100-3
My Carrier: Telus

Re: Problem installing SDK in a new installation of Momentics

BBSJdev,  Thank you reinstalling did the trick.

Now to have some fun learning how to build some apps.

Best regards,
Dan Gordon