Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Contributor
Posts: 10
Registered: ‎03-27-2012
My Device: Curve 8900
My Carrier: Tmn

Problems with development for OS 7.1

Hello all,

 

I need some help of you guys.

My company had recently buy a BB Curve 9360 with OS 7.1, we had developed an application with phonegap for previous OS (6.0) (This application works fine in the 6.0), but when I run  that application in this new cellphone more than 3 times, the phone/application crashes. It's seems that BB stay without memory.

 

Any help is appreciated,

Thanks in advance

FRombo

Contributor
Posts: 10
Registered: ‎03-27-2012
My Device: Curve 8900
My Carrier: Tmn

Re: Problems with development for OS 7.1

Hello again, just an update to my previous post:

 

We had find another BB Curve 9360 with OS 7.0 Bundle 1680, and we had test the application and works fine in that bundle. But in the client cellphone (BB Curve with OS 7.0 Bundle 2259) the application is crashing.

 

Do you have any ideia if this is a problem with this specific bundle? How can I change a bundle?

 

Best Regards,

Thanks in advance, 

 

 

 

Developer
Posts: 236
Registered: ‎07-27-2012
My Device: BlaclBerry PlayBook 16gb, BlackBerry dev alpha
My Carrier: Airtel

Re: Problems with development for OS 7.1

Unfortunately you need to redevelop the app Smiley Sad

Developer
Posts: 434
Registered: ‎07-23-2012
My Device: Blackberry 10
My Carrier: Orange

Re: Problems with development for OS 7.1

you don't need to redevelop app. but u need to debug the code and try with latest phonegap version. apart from phonegap what u have used to build apps

Thanks
-------------------------------------------------------------------------------------
Press the Accept as solution Button when u got the Solution
Press Kudo to say thank to developer.
-------------------------------------------------------------------------------------.
Developer
Posts: 158
Registered: ‎01-11-2010
My Device: 9700 | 9900 | PlayBook | Dev Alpha
My Carrier: Many :)

Re: Problems with development for OS 7.1

If it works with one bundle but not with another... then it's an issue with that bundle.  You change the bundle by upgrading / downgrading the OS on the phone.

 

 

now, the more important question is what causes the bundle to crash?  throughtly go through your code and look for memory leaks and other low-hanging fruit you can optimize.

 

good luck!

- - - - - - - - - -