Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Developer
Posts: 40
Registered: ‎04-16-2010
My Device: na
My Carrier: na

Random null Response in AJAX Request

Hi,

 

I seem to be experiencing a problem that a few others have had issues with. When making an AJAX call, the responseText/responseXML is null about half of the time, but if I try to load a large page (9k - well under 512k), it is null all the time.

 

I have installed:

 

  • BlackBerry_Email_MDS_4.1.4.exe
  • BlackBerry_Simulators_5.0.0.411_8900.exe

Other posts don't seem to have any solution. Does one exist yet?

 

Similar posts: http://supportforums.blackberry.com/t5/Web-Development/Random-null-response-in-Ajax-request/td-p/462...

 

Kind regards.

Highlighted
Retired
Posts: 3,708
Registered: ‎10-16-2008
My Device: Z10
My Carrier: Rogers

Re: Random null Response in AJAX Request

It was found in the following thread that on a servlet when the response buffer size was exceeded, the response was broken up into multiple response packages.  This seems to be the trigger for the null response.  We have not been able to reproduce this on an ASP.NET website.

 

We have also found that in later versions of the BlackBerry 5.0 OS that this issue has been corrected.  Apparently we could not re-produce the issue on the Simulators packaged with the RTM version of the Widget SDK and tooling.

 

Here is the thread and the found server side resolution.

 

http://supportforums.blackberry.com/t5/Web-Development/AJAX-Problem-on-BB-Widget/m-p/494427

Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter