Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
New Contributor
Posts: 3
Registered: ‎06-27-2012
My Device: Storm
My Carrier: Rogers
Accepted Solution

Required modules

Hi Guys!

 

First post, also my first bb app so please be gentle Smiley Happy

 

1. I've compiled an app i've build, and I wanted to first confirm how to share it

- Right now i am having users download the app through the internet, so i uploaded the entire "ota install" folder (that gets created when you compile the app) onto a directory on my website. 

- I then linked them to .jad file

 

I tested this method on my bb, and it worked perfectly fine. I also tested on another bb of a friend, same result.

 

Is this how you would typically distribute the app if you are pointing the bb to a url?

 

2. I sent this link to my client, and they responded with this:

Hi,

I just tried to download the app on bb and I got a message that says:

This application required the following modules that, which are not installed:

Net_rim_bb_web_jse_api

Net_rim_bb_browser_field2_api

Net_rim_bbapi_push

Net_rim_networkapi

 

Is there something I'm not packing properly in my app? I dont' even think I'm using bbapi_push so I don't know how that is there... 

 

please help!

New Contributor
Posts: 3
Registered: ‎06-27-2012
My Device: Storm
My Carrier: Rogers

Re: Required modules

The client just got back to me with the version of BB that they were trying to run it on...

V4.6.1.290 (platform 4.2.0.124)

That's not going to work for BB webworks is it...
Regular Contributor
Posts: 68
Registered: ‎06-12-2012
My Device: Blackberry Bold 9780
My Carrier: Vodafone

Re: Required modules

Not 100% sure about V4 but im sure it would , as far as i know webworks works in V5 and they both use the same browsers...

Not an expert my self though so this might help: http://supportforums.blackberry.com/t5/Web-and-WebWorks-Development/How-to-detect-the-BlackBerry-Bro...
New Contributor
Posts: 3
Registered: ‎06-27-2012
My Device: Storm
My Carrier: Rogers

Re: Required modules

The problem i think is that it's not a web page, it's an app?
Trusted Contributor
Posts: 134
Registered: ‎04-15-2012
My Device: Bold 9900
My Carrier: Vodafone

Re: Required modules

Webworks is supported on bb os 5 and above.