Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Developer
Posts: 222
Registered: ‎03-03-2012
My Device: Ripple, LE Z10, Dev Alpha _C, Playbook, Bold 9900
My Carrier: rogers

Ripple Emulator 9.7 code signing errors

latest errors:

1.Oh Snap! Build request failed with message: [ERROR] Error: Failed to decrypt keystore, invalid password [ERROR] Native Packager exception occurred

2.Oh Snap! Build request failed with message: [ERROR] Error: The signature on the code signing request didn't verify. The likely cause of this problem is entering an incorrect CSK password. [ERROR] Error: fail: 2Error: fail: 1 [ERROR] Native Packager exception occurred

 

what causes this output? the password&keys I use for BB10/ripple is the same one I use for Playbook. It works  fine for Playbook.

should I look into a separate set of keys for BB10?

Highlighted
Developer
Developer
Posts: 607
Registered: ‎04-29-2011
My Device: PlayBook 16GB, BB10 LE Z10 (red)
My Carrier: none

Re: Ripple Emulator 9.7 code signing errors

[ Edited ]

BUMP up this thread.

 

Same also occurred to me here when signing for BB10. My console log looks like this:

 

...
[exec] [ERROR]   Error: Failed to decrypt keystore, invalid password
[exec] [ERROR]   Native Packager exception occurred
[exec] Info: Sending request: Install and Launch
[exec] Info: Action: Install and Launch
[exec] Info: File size: 4163161
[exec] Info: Installing MyAppName.testRel_MyAppName__983a34d1...
[exec] Info: Processing 4163161 bytes
[exec] actual_dname::
[exec] actual_id::
[exec] actual_version::
[exec] result::failure 881 required signatures missing (RDK, AUTHOR)

Same keys working well when signing for PlayBook but do not work for BB10 for me too and I couldn't find a way to get it working, also not from other posts at this time.

 

Question is if I/we need new keys for BB10 or if the old ones should work and if the location of the keys need to be changed for BB10 to work?

 

BTW: I'm not using Ripple here since it would be the same.


"Like" if you liked the post.
"Accept as Solution" if the post solves your question.
Developer
Posts: 222
Registered: ‎03-03-2012
My Device: Ripple, LE Z10, Dev Alpha _C, Playbook, Bold 9900
My Carrier: rogers

Re: Ripple Emulator 9.7 code signing errors

exactly. I did post lask week wondering about a new separate set of keys for BB10. here's an image from the ripple side spewing out an error for a set of keys that are registered with server.

Developer
Posts: 222
Registered: ‎03-03-2012
My Device: Ripple, LE Z10, Dev Alpha _C, Playbook, Bold 9900
My Carrier: rogers

Re: Ripple Emulator 9.7 code signing errors

and this image matches the first line of the dos build log from you post.

rip97a.png

Developer
Developer
Posts: 607
Registered: ‎04-29-2011
My Device: PlayBook 16GB, BB10 LE Z10 (red)
My Carrier: none

Re: Ripple Emulator 9.7 code signing errors

From your last image someone could assume we need to install native SDK, but I thought we only need to install WebWorks HTML5 SDK, isn't it?


"Like" if you liked the post.
"Accept as Solution" if the post solves your question.
Developer
Posts: 222
Registered: ‎03-03-2012
My Device: Ripple, LE Z10, Dev Alpha _C, Playbook, Bold 9900
My Carrier: rogers

Re: Ripple Emulator 9.7 code signing errors

Blackberry 10 WebWorks SDK 1.0.1.6  it is.

 

I'm going to try to deploy to the dreadfully slow Vmware simulator for BB10 and see what  it does. It seems like something is missing .

 

 

 

 

Developer
Posts: 222
Registered: ‎03-03-2012
My Device: Ripple, LE Z10, Dev Alpha _C, Playbook, Bold 9900
My Carrier: rogers

Re: Ripple Emulator 9.7 code signing errors UPDATED

here is the result of dev alpha simulator running in tandem with ripple 9.7 using 'package and launch'

remember I could not package and sign( see earlier posts from today)rip97b.png

Developer
Developer
Posts: 607
Registered: ‎04-29-2011
My Device: PlayBook 16GB, BB10 LE Z10 (red)
My Carrier: none

Re: Ripple Emulator 9.7 code signing errors UPDATED

Can not see your last image, but no matter, I successfully ordered and registered new Keys for PlayBook+BB10 signing and now I can sign for BB10 with them, but not for PlayBook using console (as it is the same console input signing with Ripple). I also discussed it in another post little bit: http://supportforums.blackberry.com/t5/Testing-and-Deployment/Decrypt-Keystore-Password-suddenly-inv...


"Like" if you liked the post.
"Accept as Solution" if the post solves your question.
Developer
Posts: 222
Registered: ‎03-03-2012
My Device: Ripple, LE Z10, Dev Alpha _C, Playbook, Bold 9900
My Carrier: rogers

Re: Ripple Emulator 9.7 code signing errors UPDATED

Developer
Posts: 222
Registered: ‎03-03-2012
My Device: Ripple, LE Z10, Dev Alpha _C, Playbook, Bold 9900
My Carrier: rogers

Re: Ripple Emulator 9.7 code signing errors UPDATED

Note* Still No Gold when attempting to "package and sign"