Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Thank you for visiting the BlackBerry Support Community Forums.

BlackBerry will be closing the BlackBerry Support Community Forums Device Forums on April 1st (Developers, see below)

BlackBerry remains committed to providing excellent customer support to our customers. We are delighted to direct you to the CrackBerry Forums, a well-established and thorough support channel, for continued BlackBerry support. Please visit http://forums.crackberry.com or http://crackberry.com/ask. You can also continue to visit BlackBerry Support or the BlackBerry Knowledge Base for official support options available for your BlackBerry Smartphone.

"When we launched CrackBerry.com 10 years ago, we set out to make it a fun and useful destination where BlackBerry Smartphone owners could share their excitement and learn to unleash the full potential of their BlackBerry. A decade later, the CrackBerry community is as active and passionate as ever and I know our knowledgeable members and volunteers will be excited to welcome and assist more BlackBerry owners with their questions."

- Kevin Michaluk, Founder, CrackBerry.com

Developers, for more information about the BlackBerry Developer Community please review Join the Conversation on the BlackBerry Developer Community Forums found on Inside BlackBerry.

Posts: 124
Registered: ‎07-11-2011
My Device: 8900
My Carrier: Airtel
Accepted Solution

Ripple emulator Running Map Sample

I am running sample map app on ripple emulator.For half of the day,it was working fine for me.

Suddenly,it starts giving Blank Screen on z10 emulator.I am getting 200 for everything on command prompt.

Showing error on config validator.acess_location_services(rim permit)

Below are the logs of Command Prompt:


Starting in production mode.
Picard boldly goes on port 9910...
2013-05-08 09:12:19 GET /Maps/images/favicon.ico 200
2013-05-08 09:12:21 GET /Maps/config.xml 200
2013-05-08 09:12:21 GET /ripple/about 200
2013-05-08 09:12:21 GET /Maps/index.html 200



Posts: 64
Registered: ‎06-04-2012
My Device: Blackberry Z10
My Carrier: Bell

Re: Ripple emulator Running Map Sample

I tested the Maps app on my Ripple emulator and it works fine for me. You can disregard the error in the config panel as this is an issue within Ripple. To access GPS location on PB and lower devices, you needed to use "read_geolocation"; for BB10 devices the permission is now "access_location_services".


Have you tried to use the web inspector to see if any error messages come up in the console?


- Did this post help solve the issue? Click on "Accept as Solution"
- Was the content of this post helpful? Please give it a "Thumbs Up"

Posts: 124
Registered: ‎07-11-2011
My Device: 8900
My Carrier: Airtel

Re: Ripple emulator Running Map Sample

Thanks for your reply. Tried to watch console.

Some syntax problem was there in JS file.Removed and Working fine now.

But thing is it was working fine on real device Z10.