Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Thank you for visiting the BlackBerry Support Community Forums.

BlackBerry will be closing the BlackBerry Support Community Forums Device Forums on April 1st (Developers, see below)

BlackBerry remains committed to providing excellent customer support to our customers. We are delighted to direct you to the CrackBerry Forums, a well-established and thorough support channel, for continued BlackBerry support. Please visit http://forums.crackberry.com or http://crackberry.com/ask. You can also continue to visit BlackBerry Support or the BlackBerry Knowledge Base for official support options available for your BlackBerry Smartphone.

"When we launched CrackBerry.com 10 years ago, we set out to make it a fun and useful destination where BlackBerry Smartphone owners could share their excitement and learn to unleash the full potential of their BlackBerry. A decade later, the CrackBerry community is as active and passionate as ever and I know our knowledgeable members and volunteers will be excited to welcome and assist more BlackBerry owners with their questions."

- Kevin Michaluk, Founder, CrackBerry.com

Developers, for more information about the BlackBerry Developer Community please review Join the Conversation on the BlackBerry Developer Community Forums found on Inside BlackBerry.

New Member
Posts: 1
Registered: ‎04-08-2011
My Device: Playbook
My Carrier: None

Signing Issue - Second step of the sign in process, Registering CSJ

We are currently in the process of trying to sign our application.


When we did the second step


blackberry-signer -register -csjpin <PIN>  -cskpass <csk password from step 1> <CSJ_file>

It came back with an error.  “Bar-signer error: Smiley Frustratederver Error: Error connecting to websigner from proxy”


This is an incorrect error, as we are not restricted by a proxy.


We tried the command again, and this time it came back with

“barsigner error: server error: The HMAC information in the registration request is not valid. The likely cause of this problem is not entering the correct CSI PIN.”



Tried this a few times, and then looked in our user folder “C:\Users\<User>\AppData\Local\Research In Motion” and we noticed it had created a barsigner.db file  (bar signer.csk was already present from the first signing step).


The barsigner.db file appears to have nothing in it. 


We have tried to perform the above steps from another machine, and received the following message,

“barsigner error: server error: Unable to register client '4154749069' because there are no more registration attempts.  If you have already registered with thisserver, then you must contact RIM to register additional users.”


So believe that the csj file has been registered.



We then continued on and generated the Keystore, without any errors.

blackberry-keytool -genkeypair -keystore <output_file.p12> -storepass <create_a_password> -dname "cn=<company_name>" -alias author



We then tried to get our signature into our app

“blackberry-signer -verbose -cskpass <your CSK password> -keystore <your P12 file> -storepass <your P12 file password> <BAR_file.bar> RDK”


And have received this error

“barsigner error: Certificate chain not found for: RDK.  RDK must reference a valid KeyStore key entry containing a private key and corresponding public key certificate chain.”


 Any help please?

Posts: 34
Registered: ‎03-15-2011
My Device: Torch 9800
My Carrier: Virgin Canada

Re: Signing Issue - Second step of the sign in process, Registering CSJ

I don't know if its related but I am also having problems signing tonight. I have previously signed my app but tonight it is saying it cannot be signed because that version has already been signed. I changed the version number 4 times and it still gives me the same error everytime. 

Posts: 482
Registered: ‎10-24-2008
My Device: 9300
My Carrier: AT&T

Re: Signing Issue - Second step of the sign in process, Registering CSJ

I am getting the same error as well.


I just requested another set of keys to make sure that isn't the problem.