Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Trusted Contributor
Posts: 119
Registered: ‎11-28-2011
My Device: 9930
My Carrier: Verizon
Accepted Solution

Smartphone Application Displays Blank Page and Doesn't Load

[ Edited ]

My Webworks application installs without a problem on the smarthpone.

When I try to launch it by clicking on its icon, a blank page appears and it just sits there.

Nothing else happens.  I have only one web page in the program and it's called index.html.

This is the first app for me so it may be that I'm not getting something right in the config file. If anybody could help me on this I'd really appreciate it.

 

Here's what I have in that file:

 

<?xml version="1.0" encoding="UTF-8"?>
<widget xmlns="http://www.w3.org/ns/widgets"
xmlns:rim="http://www.blackberry.com/ns/widgets"
version="2.0" rim:header="Streamer">

<author href="http://www.xxxxxxx.googlesites.com/" email="xxxxxxx@gmail.com">PL</author>

<name> Streamer</name>

<description>A streaming radio </description>

<rimSmiley Surprisedrientation mode="auto"/>

<rim:loadingScreen backgroundImage="load_92x92.png"
onLocalPageLoad="false">
<rim:transitionEffect type="slideOver" />
</rim:loadingScreen>

<icon src="icons/desktop_68x68.png"/>

<icon src="icons/twitter.gif"/>

<rim:navigation mode="focus" />

<feature id="blackberry.ui.dialog" />

<content src="index.html" >
<rim:background src="index.html" runOnStartup="true" />
</content>

<access uri ="*"/>

<license>
Copyright (c) 2012
THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS
BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN
ACTION OF CONTRACT, INSULT OR OTHERWISE, ARISING FROM, OUT OF OR IN
CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
SOFTWARE.
</license>

</widget>

Developer
Posts: 435
Registered: ‎09-20-2011
My Device: Z10 LE, Playbook, DevAlpha C, 9900, 9380
My Carrier: Vodafone

Re: Smartphone Application Displays Blank Page and Doesn't Load

if you able to build the application then it might not be the problem with your config file. Most probably with your html page. Can you post your html code.

 

Trusted Contributor
Posts: 119
Registered: ‎11-28-2011
My Device: 9930
My Carrier: Verizon

Re: Smartphone Application Displays Blank Page and Doesn't Load

Here is my html.

 

 

<html>
<head>
<link rel="stylesheet" type="text/css" href="PP.css" />

<script LANGUAGE = "Javascript" type = "text/javascript">


</script>
<script LANGUAGE = "Javascript" type = "text/javascript" src="Populate_Programs.js">
</script>
<script LANGUAGE = "Javascript" type = "text/javascript" src="Populate_Schedules.js">
</script>
<script LANGUAGE = "Javascript" type = "text/javascript" src="Populate_Stream_Urls.js">
</script>
<script LANGUAGE = "Javascript" type = "text/javascript" src="Populate_Streams.js">
</script>
<script LANGUAGE = "Javascript" type = "text/javascript" src="Populate_Sources.js">
</script>
<script LANGUAGE = "Javascript" type = "text/javascript" src="Process_Searches.js">
</script>
<script LANGUAGE = "Javascript" type = "text/javascript" src="Populate_Favorites_Settings.js">
</script>

<script type="text/javascript" src="//platform.twitter.com/widgets.js"></script>

<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>

 

</head>
<title>XXX</title>


<body onLoad="startup_script();">

 

<div id="SearchResultBox">

<p>
<center> Please make a stream selection </center>
</div>

<p>

<div id="header-outer">
Streamer</div>


<div id="player_strip">
<div id= "internal_player_strip">
<a id="play" href="#">Play</a>
<a id="pause" href="#">Pause</a>


</div>

<div id="player_strip_msg">
<div id= "internal_player_strip_msg">
<span id="stream_status" style="color: white;"> </span>
</div>

</div>


<div id="footer-outer">


<nav id="corenav">

 


<a href="#" onClick ="populate_favorites();">Favorites</a> |
<a href="#" onClick = "populate_state();">Search by State</a> |
<a href="#" onClick ="populate_live_programs()">Search Live Programs</a> |
<a href="https://twitter.com/share" class="twitter-share-button" data-lang="en" target="_blank" text='I just downloaded XXXX on my Blackberry!'><img src="icons\twitter.gif"></a>
<a href="#" onClick ="renderOther()">More...</a>


</nav>



</div>

<script LANGUAGE = "Javascript" type = "text/javascript">


// Get the play button and append an audio play method to onclick
var play = document.getElementById("play");
play.addEventListener("click", function(){
audio.play();
// alert ("start play");
// setPlayerURLStart();
}, false);


// Get the pause button and append an audio pause method to onclick
var pause = document.getElementById("pause");
pause.addEventListener("click", function(){
var todoItems = document.getElementById('stream_status');
todoItems.innerHTML = 'Paused';
audio.pause();
// alert ("pause");
}, false);

audio.addEventListener("loadstart", function(){
var todoItems = document.getElementById('stream_status');
todoItems.innerHTML = 'Getting stream...';
},false);

audio.addEventListener("playing", function(){
var todoItems = document.getElementById('stream_status');
todoItems.innerHTML = 'Playing...';
},false);

audio.addEventListener("stalled", function(){
var todoItems = document.getElementById('stream_status');
todoItems.innerHTML = 'Buffering...';
},false);


</script>
</body>
</html>

Highlighted
Trusted Contributor
Posts: 119
Registered: ‎11-28-2011
My Device: 9930
My Carrier: Verizon

Re: Smartphone Application Displays Blank Page and Doesn't Load

I eventually got it to come up. Not sure what the problem was, though.

New Developer
Posts: 14
Registered: ‎06-09-2012
My Device: Red LE Z10; PlayBook, BlackBerry Bold 9780; Torch 9800; Dev Alpha C
My Carrier: Telus Mobility

Re: Smartphone Application Displays Blank Page and Doesn't Load

So, ... what was it? I'm having the same issue. Same app has no problem with PlayBook hardware or simulator; in fact, the BBUI.js sample application has the same issue. Splashscreen, and then nothing. 

--
James Robert Perih
http://www.cardcloud.com/jperih
Trusted Contributor
Posts: 119
Registered: ‎11-28-2011
My Device: 9930
My Carrier: Verizon

Re: Smartphone Application Displays Blank Page and Doesn't Load

I didn't pinpoint the problem. It just kind of started working.