Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
New Contributor
Posts: 6
Registered: ‎08-08-2013
My Device: BB7
My Carrier: Blackberry

Splash screen freezing on the bb7 simulator

I am making a bb7 native application. I am compiling the code in command prompt using following code -D:\BB7_Source>bbwp D:\BB7_Source\my_app.zip -g my_password -o D:\ BB7_Output.

After compilation I am getting 2 folders - StandardInstall and OTAInstall. These 2 folder containing .cod and .jad files. I have loaded StandardInstall->MyApp.cod file to the simulator. Then simulator is freezing in splash screen. It is not taking me to the next screen. But, when I am using OTAInstall->MyApp.jad file in my bb7 mobile device, then it is woriking fine. But, in simulator I am not able to install .jad file. Its know only .cod file. Then how to run my native bb7 application in simulator. Please help to come out from this problem. Thanks!

Retired
Posts: 1,382
Registered: ‎07-02-2009
My Device: BlackBerry Bold 9900
My Carrier: Bell

Re: Splash screen freezing on the bb7 simulator

What is the model # and OS version of :

 

1) The simulator you are testing on?

2) The device you are testing on?

Follow me on Twitter: @n_adam_stanley
-------------------------------------------------------------------------------------------------------------------------
Your app doesn't work? Use BlackBerry remote web inspector to find out why.
Highlighted
New Contributor
Posts: 6
Registered: ‎08-08-2013
My Device: BB7
My Carrier: Blackberry

Re: Splash screen freezing on the bb7 simulator

Thanks! You can find the model# and OS version as given bellow -

 

1). Simulator model # - 9900 and OS - 7.0 (v7.0.0.318, Platform4.0.0.127)

2). Device model # - 9900 and OS - 7.0 (v7.0.0.317, Platform5.0.0.515)

 

           In Divice its working fine. Only problem with simulator.

Retired
Posts: 1,382
Registered: ‎07-02-2009
My Device: BlackBerry Bold 9900
My Carrier: Bell

Re: Splash screen freezing on the bb7 simulator

Does your application load any remote URLs on startup (e.g. CSS or JS files, or even images)?  If so, I might expect a runtime error to occur if the simulator doesn't have a network connection and the app is trying to access some resource that it is dependant on.

 

Troubleshooting - From the simulator, open the browser and try to navigate to any website. 

Follow me on Twitter: @n_adam_stanley
-------------------------------------------------------------------------------------------------------------------------
Your app doesn't work? Use BlackBerry remote web inspector to find out why.
New Contributor
Posts: 6
Registered: ‎08-08-2013
My Device: BB7
My Carrier: Blackberry

Re: Splash screen freezing on the bb7 simulator

    Thanks! You are right, I am calling - http://maps.google.com/maps/api/js?sensor=false. After remove this part, now my splash screen is not freezing. But, after splash screen, it is showing me a white screen.

Retired
Posts: 1,382
Registered: ‎07-02-2009
My Device: BlackBerry Bold 9900
My Carrier: Bell

Re: Splash screen freezing on the bb7 simulator

It sounds like there might be a runtime error.  Perhaps a dependency on the code in that JS file is not available and the app is crashing?

 

I would suggest whitelisting all Google domains that the app might be using (need an access element for every different *.google) domain.

 

Otherwise, I would recommend using remote web inspector to debug any potential runtime errors:

https://developer.blackberry.com/html5/documentation/web_inspector_overview_1553586_11.html

Follow me on Twitter: @n_adam_stanley
-------------------------------------------------------------------------------------------------------------------------
Your app doesn't work? Use BlackBerry remote web inspector to find out why.