Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
New Developer
Posts: 4
Registered: ‎07-25-2008
My Device: Not Specified

Transparent GIF used as Links

I have found an issue with images that have transparencies when used as hyper links on mobile web pages.

The issue i found was when the background is black, and the image has transparent sections. As the cursor moves over each of the links, it causes the transparent sections to turn white. This causes ugly browsing experience.

I had to implement a workaround whereby there is no transparency.

This is reproducible in the simulator too.

Is there a fix for this?
BlackBerry Development Advisor
Posts: 15,784
Registered: ‎07-09-2008
My Device: BlackBerry PRIV
My Carrier: Bell

Re: Transparent GIF used as Links

On a BlackBerry, it is normal for transparent sections of an image to be highlighted when an image has focus.  The actual highlight colour can vary based on the current theme in use on the BlackBerry.  Themes can be changed by going to Options, Theme on the BlackBerry.
Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
New Developer
Posts: 3
Registered: ‎09-14-2008
My Device: Not Specified

Re: Transparent GIF used as Links

"The issue i found was when the background is black, and the image has transparent sections. As the cursor moves over each of the links, it causes the transparent sections to turn white. "

 

Yes...and the images stay white. This is an annoying issue.

 

 


MSohm wrote:
On a BlackBerry, it is normal for transparent sections of an image to be highlighted when an image has focus.

When the image has focus...that would be fine, but focus is not being released and the images are remaining white.

When you move the cursor to the next link the previous link that the cursor passed over remains highlighted white...???

 

Any help resolving this matter would be greatly appreciated.

 

 

BlackBerry Development Advisor
Posts: 15,784
Registered: ‎07-09-2008
My Device: BlackBerry PRIV
My Carrier: Bell

Re: Transparent GIF used as Links

What BlackBerry model and handheld software version are you testing with?  This can be found under Options, About on the BlackBerry.

 

Can you provide a URL of a page that exhibits this behavior?

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Guru I
Posts: 19,020
Registered: ‎07-29-2008
My Device: Passport, Playbook, 9320BES
My Carrier: Bouygues _ SFR

Re: Transparent GIF used as Links

I have also observed that, but I can't find an example right now.
I have provided one for you here (an animated gif), that works fine on 4.2.2.

note : the alt="" attribute is missing so it's not HTML4-valid.

 

http://xandrex.free.fr/Blackberry/test.gif.link.html




The search box on top-right of this page is your true friend, and the public Knowledge Base too:
New Developer
Posts: 3
Registered: ‎09-14-2008
My Device: Not Specified

Re: Transparent GIF used as Links

[ Edited ]

My apologies, I should have stated model/version in my first post...it is:

 

model/version

8330/v4.3.0.124

 

 

I whipped up a testing page : http://blackberry.sytes.net:7887 for an example.

 

The browser is not handling the transparency properly...I haven't played with animated gif's as of yet.

olafdunn's workaround will do the job...but we shouldn't have to remove the transparency...

This forces us to recolor all the image links Through Out The Entire Website.

Message Edited by willryals on 09-18-2008 10:02 PM
New Developer
Posts: 3
Registered: ‎09-14-2008
My Device: Not Specified

Re: Transparent GIF used as Links

Hate to double post, but I can no longer edit my post and am removing the test link as well as my transparency Smiley Sad

Crappy workaround being implemented.