Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Highlighted
Contributor
Posts: 15
Registered: ‎01-30-2013
My Device: bb10 developer prototype from CES
My Carrier: 4082341385
Accepted Solution

Trouble submitting app

I create a bar file using the chrome extension.this bar file works on the bb10 phone emulator.  Do I need to add somehting to it when I submit it to the store? I tried zipping it and uploading but in "manage products" I keep getting the error that says "invalid format".

 

What devices do I select?  It works in the bb10 emulator but that is all I know.  Do I need to somehow create a release xml file?  Is there a sample for the bb10 emulator?

Developer
Posts: 232
Registered: ‎01-30-2011
My Device: Dev Alpha C, Z10 LE
My Carrier: P4

Re: Trouble submitting app

You need not to zip Your bar file. You should upload only bar file.

 

This bar file must be signed using Your signign key. Here is a good instruction from BB.

All time online Smiley Very Happy
Developer
Posts: 1,229
Registered: ‎03-20-2011
My Device: Playbook, Z10 LE, Dev Alpha B, 2x Dev Alpha C
My Carrier: 3, Orange, Vodafone

Re: Trouble submitting app

I think you may be doing something I keep falling for

 

On the release page scroll down to the bottom and click on "Add File Bundle" then add the bars t the end of that process

 

Select everything BB10 and make sure you sign it

 

The file upload occurs just before you finish

 

Sounds like this is what's wrong




Click the like button if you find my posts useful!
Contributor
Posts: 15
Registered: ‎01-30-2013
My Device: bb10 developer prototype from CES
My Carrier: 4082341385

Re: Trouble submitting app

I'm using the ripple emulator which seems to claim it "packages and signs". when I look at the terminal log, it looks like it creates a bar and zip file.  what file to I grab out of the /tmp directory as signed?

 

it creates:

/tmp/device/StarSaver.bar

/tmp/device/StarSaver.zip

/tmp/simulator/StarSaver.bar

/tmp/simulator/StarSaver.zip

 

when I add them at the bottom I get the errors:

 

  • Invalid binary file (adverts.html7698014972889632231.html)
  • Invalid binary file (app.js6550798077027271294.js)
  • Invalid binary file (app.json6972319101882890855.json)
  • Invalid binary file (cache.appcache7016613653638506404.appcache)
  • Invalid binary file (config.xml2966119609678290894.xml)
  • Invalid binary file (icon.png5845057218568216663.png)
  • Invalid binary file (iconStarSaver.png4637846638973065402.png)

etc.

 

Developer
Posts: 1,229
Registered: ‎03-20-2011
My Device: Playbook, Z10 LE, Dev Alpha B, 2x Dev Alpha C
My Carrier: 3, Orange, Vodafone

Re: Trouble submitting app

Which file are you submitting?

 

I don't use Ripple

 

PM me and I'll do a direct build to help you out if you want (I'll give you my email via the PM)

 




Click the like button if you find my posts useful!
Contributor
Posts: 15
Registered: ‎01-30-2013
My Device: bb10 developer prototype from CES
My Carrier: 4082341385

Re: Trouble submitting app

can't find PM option
Developer
Posts: 2,462
Registered: ‎11-04-2010
My Device: Bold 9700

Re: Trouble submitting app

Hey pkeliner,

 

You need to submit this one: /tmp/device/StarSaver.bar using the "Add Bundle" link. Good luck!

J. Rab (Blog) (Twitter)
--
1. If you liked my post or found it useful please click on the thumbs up and provide a Like!
2. If my post solved your problem please click on the Accept as Solution button. Much appreciated!

Approved Apps: OnTrack | ssShots | Hangman
Developer
Posts: 1,229
Registered: ‎03-20-2011
My Device: Playbook, Z10 LE, Dev Alpha B, 2x Dev Alpha C
My Carrier: 3, Orange, Vodafone

Re: Trouble submitting app

Yeah, this is what I thought was wrong

 

Easiest solve is simply to compile from command-line then test install on device

 

He may be using Mac / rather than \ thou so the howto may be more complicated




Click the like button if you find my posts useful!
Developer
Posts: 1,229
Registered: ‎03-20-2011
My Device: Playbook, Z10 LE, Dev Alpha B, 2x Dev Alpha C
My Carrier: 3, Orange, Vodafone

Re: Trouble submitting app

Built and tested plus a submit test (left in draft and bundle cancelled)

 

I wonder if Ripple is missing an output Dir?

 

I've given him explivit instructions apart from build prom command

 

Ripple sorta sux anyway - you need a device




Click the like button if you find my posts useful!
Contributor
Posts: 15
Registered: ‎01-30-2013
My Device: bb10 developer prototype from CES
My Carrier: 4082341385

Re: Trouble submitting app

After carefully reading the directions that say "just because it says it is successful, it may not be" I looked at the log and sure enough signing failed.  You can see from my screen shot that I have the password there.  what am I missing?