Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Retired
Posts: 3,708
Registered: ‎10-16-2008
My Device: Z10
My Carrier: Rogers

Try out your Widgets on BlackBerry 6

[ Edited ]

Hi Everyone,

 

We have just recently released the latest Widget/WebWorks tooling so that you can build applications on both BlackBerry 6 and OS 5.0

 

You can download the latest tools here:

http://na.blackberry.com/eng/developers/browserdev/devtoolsdownloads.jsp

 

Also check out the below article for all the details on the JavaScript Toolkit that will help you bridge the gap between Gears and HTML5

 

http://supportforums.blackberry.com/t5/Web-Development/Supporting-Gears-using-HTML5-in-BlackBerry-Wi...

Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter
Contributor
Posts: 13
Registered: ‎02-18-2010
My Device: 8910
My Carrier: China Mobile

Re: Try out your Widgets on BlackBerry 6

Hi, you mentioned that "We have just recently released the latest Widget/WebWorks tooling so that you can build applications on both BlackBerry 6 and OS 5.0".

 

So, the WebWorks do support OS 5.0?

My situation here is that there is a lot of OS 5.0 device customers.

 

Thank you!

Best Regards,
Yang Jiang

Retired
Posts: 3,708
Registered: ‎10-16-2008
My Device: Z10
My Carrier: Rogers

Re: Try out your Widgets on BlackBerry 6

Yes, WebWorks is available on both v5.0 and BlackBerry 6
Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter
Developer
Posts: 124
Registered: ‎09-06-2010
My Device: Not Specified

Re: Try out your Widgets on BlackBerry 6

I'd like to use the latest Widget SDK, packager and Web plug-in for Eclipse.  The Web plugin seems to require Eclipse 3.6, which I have installed on Windows 7.  The Web plugin installs fine.

 

However, for my project, I need to use the Java plugin as well, for the JavaScript extenions.  The latest release of the Java plugin only seems to work with Eclipse 3.5 and does not install on 3.6 due to a dependency error.

 

When will the Java plugin be available for Eclipse 3.6 so I can do everything in a single environment?

 

Thanks.

Highlighted
Contributor
Posts: 13
Registered: ‎02-18-2010
My Device: 8910
My Carrier: China Mobile

Re: Try out your Widgets on BlackBerry 6

Hi, thank for replying that WebWorks is available on both v5.0 and BlackBerry 6. great news.

 

Further question, how to compile the webworks? tools, process, installation guide, guide book? Smiley Happy

 

Thank you.

Retired
Posts: 3,708
Registered: ‎10-16-2008
My Device: Z10
My Carrier: Rogers

Re: Try out your Widgets on BlackBerry 6

If you scroll the bottom of the following page you will find documentation, samples, tutorials, videos etc.

 

http://na.blackberry.com/eng/developers/browserdev/widgetsdk.jsp

Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter