Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
New Developer
Posts: 3
Registered: ‎06-24-2008
My Device: Not Specified

Unable to Login in WAPEmail in Blackberry

Hi,

Currently we are facing a unique issue w.r.t Blackberry Devices.We are having a WAP Email application,which we are able to login in various devices like LG,Samsung and Nokia.But we are unable to login only in Blackberry Devices.

The login page is correctly displayed , even after entering username & password.The page just refreshes and stays on the login page and cannot go futher.

The email application is developed in ASP.Net 2.0 Mobile and is https enabled.

Do we need to change any configruation setting anywhere.Please let me know if I am missing something.Any help would be greatly appreciated.

 

Thanks

-SR

Retired
Posts: 18
Registered: ‎07-14-2008
My Device: Not Specified

Re: Unable to Login in WAPEmail in Blackberry

[ Edited ]

Please review the following article to ensure that IIS/ASP.Net is properly recognizing the capabilities of the BlackBerry Browser.

 

How To - Configure .NET 2.0 for BlackBerry Browser support 
Article Number: DB-00593

 

If that doesn't work, check the markup sent to the device to see if all of the JavaScript required for posting was generated correctly.

 

Jeremy

Message Edited by JWeber on 07-16-2008 03:55 PM
Jeremy Weber
Sr Application Development Consultant
Research In Motion
BlackBerry Development Advisor
Posts: 15,753
Registered: ‎07-09-2008
My Device: BlackBerry PRIV
My Carrier: Bell

Re: Unable to Login in WAPEmail in Blackberry

If the page requires JavaScript, also verify that JavaScript is enabled in the BlackBerry Browser.  To do so open the browser, select Options from the menu, then Browser Configuration and verify that Support JavaScript is checked off.
Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
New Developer
Posts: 3
Registered: ‎06-24-2008
My Device: Not Specified

Re: Unable to Login in WAPEmail in Blackberry

Hi,

Thank you for your quick reply.
I have already added the Browser Support file in Prod Servers. But still it does not work.
We are able to view and login in the WAPEmail from Simulator in DEV enviroment.But unable to login in Prod Env from both Simulator as well as Device.

In production, the first page of login gets rendered and the user is able to type userid and password. Once he clicks on "sign in" button, the request is being sent as I see the progress bar. However, It lands back in login page without any error.

Please Note that in Blackberry like any other device, accessess the site via our company’s WAPGateway.Does Gateway has any influence over the login w.r.t Blackberry.

Thanks,
-SR

Highlighted
BlackBerry Development Advisor
Posts: 15,753
Registered: ‎07-09-2008
My Device: BlackBerry PRIV
My Carrier: Bell

Re: Unable to Login in WAPEmail in Blackberry

Can you verify what browser you are using on the BlackBerry?  Is it the BlackBerry Browser (BlackBerry Enterprise Server), Internet Browser (BlackBerry Internet Service) or WAP Browser (Carrier's WAP Gateway)?  You can see this on the BlackBerry under Options, Advanced Options, Browser.

 

Are you able to view what is happening on the server side?  Is the authentication failing?  Or is it accepted and the server is trying to redirect the user?  What action(s) should take place after login (redirection, load a new page, JavaScript method fires, etc...)?

 

Are you using the BlackBerry Simulator in your development environment?

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker