Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

New Developer
Posts: 2
Registered: ‎07-27-2009
My Device: Not Specified

VS 2008 Plugin (vs_plugin.17.exe) and jQuery 1.2.3

[ Edited ]

I tried to create simple site that uses jQuery and I can't run it using VS2008 plugin and simulator that provided with it.
I am on Vista(Home basic) / VS 2008 SP1 Team system.
Simulator just handing-up without any information messages.

    <form id="form1" runat="server">
    <script language="javascript" type="text/javascript">
        function testAction() {
            alert("Query element by css selector:" + $(".C1Container").get(0));
        <div class="C1Container" style="font-family:Helvetica;">
            <aspSmiley FrustratedcriptManager ID="ScriptManager1" runat="server">
                <aspSmiley FrustratedcriptReference Path="~/Script/jquery-1.2.3.js" />
            </aspSmiley FrustratedcriptManager>
            Hi BlackBerry. This is a test.
            <a class="C1Link" href="javascript&colon;testAction()">testAction</a>

However jQuery works on standalone simulator (I tried, 9500 Vodafone)

Best regards, Dmitri.
Message Edited by dmadima on 07-27-2009 04:23 AM
Message Edited by dmadima on 07-27-2009 04:30 AM