Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
New Developer
Posts: 5
Registered: ‎09-24-2009
My Device: Not Specified
Accepted Solution

VS Plug-in error "Failed to init debug helper"

Hi there

 

I'm currently trying to get started using the BBerry plug-in v1.2 for Visual Studio 2008 (SP1). Whenever I try to browse a new or existing website using the Blackberry Browser, I get the error "Failed to init dubug helper"

 

I've tried following the getting started guides but with no luck. I've also reinstalled the plug-in, again with no success.

 

If anyone could help, I'd be very grateful!

Retired
Posts: 3,708
Registered: ‎10-16-2008
My Device: Z10
My Carrier: Rogers

Re: VS Plug-in error "Failed to init debug helper"

Can you post up your Operating system (XP or Vista) and 32bit or 64bit.

 

As well list the simulator and OS version you are debugging with.

 

That will help us understand the environment and diagnose the problem 

Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter
New Developer
Posts: 5
Registered: ‎09-24-2009
My Device: Not Specified

Re: VS Plug-in error "Failed to init debug helper"

Hi Tim

 

Thanks for the response.

 

I'm using;

 

Vista Ultimate (32 bit) with SP2

Visual Studio 2008 SP1 Professional

Blackberry Plug-in for Visual Studio v1.2.0.31

 

The option to Browse With... Blackberry Browser appears but the error occurs when I select it to view either a new or existing website. The error occurs before the Simulator loads up...

 

Therefore not sure how to get the Simulator / OS version I'm debugging with?

 

Hope this helps?

 

J

Retired
Posts: 3,708
Registered: ‎10-16-2008
My Device: Z10
My Carrier: Rogers

Re: VS Plug-in error "Failed to init debug helper"

are there any log files in the "bin" directory where the plug-in was installed?  If so, can you post them?
Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter
New Developer
Posts: 5
Registered: ‎09-24-2009
My Device: Not Specified

Re: VS Plug-in error "Failed to init debug helper"

All that's in the log file are a couple of entries from when I reinstalled this morning:

 

<entry type="Information" date="24 Sep 2009 09:39:38">BrowserLauncher: Install called...</entry>
<entry type="Information" date="24 Sep 2009 09:39:38">BrowserLauncher: browsers.xml updated.</entry>

 

 

Retired
Posts: 3,708
Registered: ‎10-16-2008
My Device: Z10
My Carrier: Rogers

Re: VS Plug-in error "Failed to init debug helper"

So there are no other errors in the log after you try and run the simulator unsuccessfully?
Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter
New Developer
Posts: 5
Registered: ‎09-24-2009
My Device: Not Specified

Re: VS Plug-in error "Failed to init debug helper"

Hi Tim

 

Nope, that's all that's in the log.

 

I've done a bit more digging and I can successfully launch the simulator from C:\Program Files\Research In Motion\BlackBerry VS9 Plugin 1.2\handheld\simulator_4_6_0\fledge.exe. It just won't launch from within VS for viewing a website developed therein (I've just tried by creating an empty web and merely adding 1 html file and attempted to Browse with... Blackberry Browser, as advised in the 'getting started guide', but to no avail).

 

 

Retired
Posts: 3,708
Registered: ‎10-16-2008
My Device: Z10
My Carrier: Rogers

Re: VS Plug-in error "Failed to init debug helper"

I noticed that you are using Vista.  One of the limitations of the tool right now is that you must launch Visual Studio using "Run As Administrator".  Give that a try and see if it works for you.
Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter
New Developer
Posts: 5
Registered: ‎09-24-2009
My Device: Not Specified

Re: VS Plug-in error "Failed to init debug helper"

Hi Tim

 

Thank you, thank you, thank you!

 

Works a treat! May be worth adding this to the getting started guides?

 

Once again thanks for your help

 

J