Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Posts: 27
Registered: ‎07-24-2009
My Device: Not Specified
Accepted Solution

Visual Studio Plugin Unable to Attach to Process

I have Win 2k3
I have Visual Studio Team System 2008 (Version 9.0.30719.1 SP)

And Microsoft .NET Framework Version 3.5 SP1)


I installed Email/MDS thingy (BlackBerry_Email_MDS_4.1.2.17.exe)

I installed BlackBerry Bold (8900-Rogers) Emulator (BlackBerry_Simulators_4.6.1.94_8900-Rogers.exe).

I installed the visual studio plugin (vs_plugin.17.exe)


I run Start Menu\Programs\Research In Motion\BlackBerry Email and MDS Services Simulators 4.1.2\MDS.lnk

I start Visual studio

I click new web site (just have default.aspx) and then i go to right click solution and dont see  "Browse With"


In visual studio I found: "Tools"->"Options" I see Blackberry node (Set default ASP.NET simulator as: Blackberry 9000)


Then I tried to open the BlackBerry emulator hit my page and then I wanted to click "Attach to Process"

but I know which process to attach to.


What Am I missing?

Posts: 3,708
Registered: ‎10-16-2008
My Device: Z10
My Carrier: Rogers

Re: Visual Studio Plugin Unable to Attach to Process

It looks like you installed a few too many things Smiley Happy


The Visual Studio plugin (v1.2) includes a Bold simulator and an MDS simulator.  When you do a browse with or a debug, it will launch its packged MDS simulator.  I believe you will get a port conflict.


Make sure you don't have your separately downloaded MDS simulator running before using the tool.  For the Beta version it only supports the Bold simulator that is packaged with the tool. The RTM version will have support to detect other simulators.


Take a look in the Known Issues list to see if you can find a resolution to your issue http://na.blackberry.com/eng/support/docs/subcategories/?userType=21&category=BlackBerry+Web+Develop... 


Also try creating a web application v.s. a web site.  If I remember correctly there was a known issue around only supporting one in the Beta.


RTM should be coming very soon with lots of fixes and new functionality!!

Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter
Posts: 27
Registered: ‎07-24-2009
My Device: Not Specified

Re: Visual Studio Plugin Unable to Attach to Process

Ah WebSite it works for. WebApplication it does not work for.


The instructions are also incorrect. You should not right click on the solution and click "Browse with" you should click on the Project and click "Browse with"


Thanks tneil :-)