Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
New Contributor
Posts: 2
Registered: ‎04-11-2011
My Device: None
My Carrier: Fido
Accepted Solution

WebWorks app broke after PlayBook 1.0.5 update

[ Edited ]

I just installed PlayBook's latest 1.0.5 software update, and my WebWorks app stopped working. The app was uploaded to the device using development mode and worked fine before the update. When launching the app, the app would freeze in a black screen.

 

I have tried to mess around with config.xml and rebuilt the app a few times. The problem wouldn't go away. I have even tried to create a minimal WebWorks app with a hello world index.html, and that minimal app didn't work either.

 

Any help with this issue would be very much appreciated!

 

Thanks,

Brad

 

ps. below is my config.xml: 

<?xml version="1.0" encoding="utf-8"?>
<widget xmlns="http://www.w3.org/ns/widgets"
        xmlns:rim="http://www.blackberry.com/ns/widgets"
        version="2.0.0"
        rim:header="RIM-Widget: rim/widget">
  <name>Test</name>

  <author rim:copyright="2011">test</author>

  <content src="index.html" />
</widget>

 and index.html:

<!DOCTYPE html>
<html>
<head>
  <title>Hi</title>
</head>
<body>
  <h1>Hello world!</h1>
</body>
</html>

 

Contributor
Posts: 34
Registered: ‎03-15-2011
My Device: Torch 9800
My Carrier: Virgin Canada

Re: WebWorks app broke after PlayBook 1.0.5 update

This may seem like a silly question but are you using the latest version of the webworks sdk? i believe the latest update was the one we were warned about if still using the beta version that your apps wouldn't work.
New Contributor
Posts: 2
Registered: ‎04-11-2011
My Device: None
My Carrier: Fido

Re: WebWorks app broke after PlayBook 1.0.5 update

Yes, I have just been told with the same info. Right now the latest SDK has been installed, and I'm waiting for the new code signing key. (Deleted the old one by mistake while removing the old SDK.) Hopefully that'll resolve the issue.

 

Thanks for your reply.

 

Brad

Highlighted
Retired
Posts: 3,708
Registered: ‎10-16-2008
My Device: Z10
My Carrier: Rogers

Re: WebWorks app broke after PlayBook 1.0.5 update

Hi Brad,

 

Yes there is an incompatibilty for apps built with the Beta version of the WebWorks SDK on 1.0.5 as outlined in the sticky post at the top of the forum

 

http://supportforums.blackberry.com/t5/Web-and-WebWorks-Development/IMPORTANT-PlayBook-WebWorks-Noti...

 

Our developer relations team has also been sending out emails to registered vendors of App World who had WebWorks apps built with the Beta version to upgrade.

 

The above link should outline the details.

Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter