Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Developer
Posts: 30
Registered: ‎10-30-2012
My Device: Z10 Limited Edition / PlayBook / BB10 Dev A-B-C / Bold 9700
My Carrier: H3G Italy
Accepted Solution

WebWorks+bbui.js app on Dev Alpha doesn't respond to tap

Hi guys Smiley Happy

 

I've just installed my webworks+bbui-0.9.4.js app on my dev alpha.

 

when I start my app, the first page that appears to me is the login: an email text field, one for password and a submit button.

 

 

But when I tap on elements no one response by dev alpha, no keyboards appears and submit button doesn't work.

 

If I test this app on ripple via browsers it works fine Smiley Sad

 

Any ideas?

 

Here the html code of the page:

<div data-bb-type="round-panel" id="formLogin">
<div data-bb-type="panel-header">Use your Producteev.com Account</div>
<form id="loginForm" onsubmit="return Login.actions.login.do();">
<div data-bb-type="label-control-container">
<div data-bb-type="row">
<div data-bb-type="label">Email</div>
<input type="email" placeholder="Producteev account email" required="required"
value="" id="login_email" size="25">
</div>
<div data-bb-type="row">
<div data-bb-type="label">Password</div>
<input type="password" placeholder="producteev account pwd" required="required"
value="" id="login_pwd" size="25">
</div>
<div data-bb-type="row">
<div data-bb-type="label"></div>
<div data-bb-type="button" data-bb-style="stretch"
onclick="document.getElementById('buttSubmit').click()">Sign in</div>
</div>
</div>
<input type="submit" value="Submit" id="buttSubmit" style="display:none">
</form>
</div>

 

Tnx

MA

Developer
Posts: 134
Registered: ‎05-19-2012
My Device: Torch 9800, PlayBook 64GB, Dev Alpha
My Carrier: VIVO Brazil

Re: WebWorks+bbui.js app on Dev Alpha doesn't respond to tap

Had you tried the Remote Web Inspector by using the -d flag while compilling the WebWorks application via bbwp? It's great to diagnose this kind of stuff.

If I helped you please click the "Like" button to support my work.
My apps: CherryNotes - Bookmarked - Requests
Social Me: about.me - Twitter
Developer
Posts: 30
Registered: ‎10-30-2012
My Device: Z10 Limited Edition / PlayBook / BB10 Dev A-B-C / Bold 9700
My Carrier: H3G Italy

Re: WebWorks+bbui.js app on Dev Alpha doesn't respond to tap

Hi, tnx for the answer.

 

I've tried but no events were fired! neither when tapping a text field neither when clicking on a button.

 

So I rebuilt the same app (source code, bbui.js ecc.. the only change I made was in config.xml in which I removed the attribute ID) for playbook and it works fine. on playbook it works as in ripple!

 

I can't undestand.

 

Uff, I will try with the webinspector again Smiley Sad

 

Tnx.

MA

 

 

Developer
Posts: 134
Registered: ‎05-19-2012
My Device: Torch 9800, PlayBook 64GB, Dev Alpha
My Carrier: VIVO Brazil

Re: WebWorks+bbui.js app on Dev Alpha doesn't respond to tap

That's very strange looks like a WebWorks bug.
If I helped you please click the "Like" button to support my work.
My apps: CherryNotes - Bookmarked - Requests
Social Me: about.me - Twitter
Developer
Posts: 30
Registered: ‎10-30-2012
My Device: Z10 Limited Edition / PlayBook / BB10 Dev A-B-C / Bold 9700
My Carrier: H3G Italy

Re: WebWorks+bbui.js app on Dev Alpha doesn't respond to tap

[ Edited ]

Yes.

 

If the app is the same then the only difference that remains is dev alpha vs. playbook.

 

I rebuilt the application because I thought that the problem was in my source code and I was hoping to find it. Instead I discovered that my app works fine ......

 

If so it should be a grave problem cause in a few weeks bb10 starts its adventure.

In this case if you want and it's not a problem I can give you my .bar, so you can test it to discover if it is a webworks bug.

 

Bye

 

BlackBerry Development Advisor
Posts: 761
Registered: ‎10-01-2009
My Device: All
My Carrier: N/A

Re: WebWorks+bbui.js app on Dev Alpha doesn't respond to tap

If you're running the newest OS on your Dev Alpha, it sounds like you may be packaging with an old SDK.

 

Make sure you're using 1.0.3.8 SDK, or this exact problem will happen.

 

You can download the new SDK form here, https://developer.blackberry.com/html5/download/

 

Highlighted
Developer
Posts: 30
Registered: ‎10-30-2012
My Device: Z10 Limited Edition / PlayBook / BB10 Dev A-B-C / Bold 9700
My Carrier: H3G Italy

Re: WebWorks+bbui.js app on Dev Alpha doesn't respond to tap

Hi guys Smiley Happy

 

After installing the webworks gold SDK and the last OS 10 on dev alpha,

all the problems about the touch events have gone OK Smiley Happy

 

now I've other problems, but I will open new threads.

 

For me this request is closed.

 

tnx you all.

 

MA