Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Posts: 10
Registered: ‎03-31-2011
My Device: Bold 9930
My Carrier: Verizon
Accepted Solution

Webworks SDK/Plug In not working

[ Edited ]

I have installed the following items but am still getting errors when I try to build:


Visual Studio 2008

Webworks SDK

Java JDK 1.6.24 - 32 bit

Webworks Plug-in 2.5 VS9

I have also tried setting the environment variable as well to C:\Program Files (x86)\java\jdk1.6.0_24\bin


The errors i am getting are as follows:


1.  Error occurred during initialization of VM

2.  Unable to load native library:  Can't load AMD 64-bit .dll on a IA 32-bit platform

3.  CreateCodFile failed


I should mention I am running Windows 7 Home Premium N, 64 bit, not sure if this makes a difference.  This is only for the phone development, not the Playbook.


Thanks for any thoughts and advise.

Posts: 10
Registered: ‎03-31-2011
My Device: Bold 9930
My Carrier: Verizon

Re: Webworks SDK/Plug In not working

Solved the issue.  After doing multiple uninstalls and reinstalls without any luck, I did it one last time.  This time however, after I deleted the Java through control panel, I went in and deleted the folder itself from within the Program Files (x86) folder.  Then after reinstalling everything again, it works.  I beleive that even though I uninstalled it all before, it was still referencing the 64-bit JDK that was installed at a previous time.