Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Regular Contributor
Posts: 60
Registered: ‎03-07-2011
My Device: Not Specified

Re: Webworks app freezes on PlayBook UNLESS Web Inspector is running...

EDIT--I am also using a real device, not a simulator.
Regular Contributor
Posts: 60
Registered: ‎03-07-2011
My Device: Not Specified

Re: Webworks app freezes on PlayBook UNLESS Web Inspector is running...

Hi,

 

Just by way of additional information, I was using my PlayBook to do some poking around on the Web and noticed some odd behavior from the browser.  I had multiple tabs opened at the same time and noticed that every time I switched from one tab to another, the splash page for one of my non-working webworks apps would briefly appear on the screen, and then the other tab information/page would show up.  I know that WebWorks apps use the browser engine, but should splash pages really appear there at that time?  Could this be related in any way to the other issues I have described in previous posts in this thread?

 

Note, the apps that don't work on my PB are ones which incorporate WebDB and, at least in one case, worked before the OS2.0 update.

 

Regular Contributor
Posts: 60
Registered: ‎03-07-2011
My Device: Not Specified

Re: Webworks app freezes on PlayBook UNLESS Web Inspector is running...

Hi twindsor,

 

I have now tried reinstalling my OS to currently available (non-beta) version and the result is the same.

 

I did not see this matter on the issue tracker.  Please let me know ASAP if you would like me to include this issue in the tracker.

 

Thank you.

Retired
Posts: 856
Registered: ‎07-15-2008
My Device: Passport
My Carrier: Bell

Re: Webworks app freezes on PlayBook UNLESS Web Inspector is running...

I haven't had an opportunity to investigate it in depth yet, but I will do so. You can submit it to the issue tracker if you have a chance, as it should go there anyway.

Tim Windsor
Open Source Technical Lead
Regular Contributor
Posts: 60
Registered: ‎03-07-2011
My Device: Not Specified

Re: Webworks app freezes on PlayBook UNLESS Web Inspector is running...

Hi twindsor,

 

I know you guys are crazy busy, but just thought I'd see if you have had a chance to upload this to a PB device.

 

Also, I did try to put this on the issue tracker, but could not get past the main screen as the required "version" parameter would never work.  Sorry.

 

Thank you.

Retired
Posts: 856
Registered: ‎07-15-2008
My Device: Passport
My Carrier: Bell

Re: Webworks app freezes on PlayBook UNLESS Web Inspector is running...

Sorry, just got back from vacation. Will try to investigate this week.

Tim Windsor
Open Source Technical Lead
Regular Contributor
Posts: 60
Registered: ‎03-07-2011
My Device: Not Specified

Re: Webworks app freezes on PlayBook UNLESS Web Inspector is running...

No apologies necessary.  I hope you had a great vacation.

 

You never know, but here's hoping the new OS release will solve some problems.

Retired
Posts: 856
Registered: ‎07-15-2008
My Device: Passport
My Carrier: Bell

Re: Webworks app freezes on PlayBook UNLESS Web Inspector is running...

Have you continued to have problems with SQLite since upgrading to 2.0.1.358? I built the attached sample to test this and tested on 2.0.1, 2.1.0, and BB10. When I create the db and insert items, it's still there when I reopen the app in all cases.

Tim Windsor
Open Source Technical Lead
Regular Contributor
Posts: 60
Registered: ‎03-07-2011
My Device: Not Specified

Re: Webworks app freezes on PlayBook UNLESS Web Inspector is running...

@twindsor Hi Tim,

 

Thanks for your response.  I hope the party was good in Orlando.

 

I will try your .zip and get back to you.  As a reminder, the problem I was having was not a persistence of data, but that the app itself would freeze execution every second time it was opened.  However, when I would shut the app down and restart, it would take a bit longer to restart but the app would then work again.

 

Also, would you please advise if you tested this on a simulator or emulator versus on the actual device?  I always test on the device itself as I have regularly found differences between sims/ems and the real thing.

 

Finally, in answer to your question, the update to the new OS on the device (2.0.1.358) didn't seem to change the issues.

 

Thank you.

Retired
Posts: 856
Registered: ‎07-15-2008
My Device: Passport
My Carrier: Bell

Re: Webworks app freezes on PlayBook UNLESS Web Inspector is running...

I'm testing on devices only, and I see no freezing. I looked again at your sample (it was the basis for my own), but I see no real differences in the SQL portion of it. However, and this may be a long shot, there are differences in the config.xml. You say that the slower loading time and freezing appears on the second launch? Could there be a connection to the way the configuration is done?

 

You have:

 <rim:loadingScreen onFirstLaunch="true" >
  </rim:loadingScreen>

in your config. Can you try without that? Do you see any other differences between your app and the sample I sent?

Tim Windsor
Open Source Technical Lead