Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Posts: 1
Registered: ‎06-11-2010
My Device: 9630
My Carrier: Verizon

newbie with simulator javascript issues

I'm new at this and hope someone can provide some insight...


I am having some trouble getting a particular javascript file to load up on my blackberry simulator.  I have installed the MDS & Email service simulators (version 4.1.4) and have two device simulators set up (Verizon 9630 and AT&T 9700).  Both have the problem – I must note that I do not have a physical device to test on.  Anyway, I first had the issue on an asp.net page and have since setup a dummy html page with the script reference in the header.  The script that will not load is jquery version 1.3.2 – I have also tried 1.4.1 and 1.4.2.  When looking at the source in the blackberry simulator, I get an empty script tag where the reference used to be.  Below is the original source with the blackberry reported source:



    <script src="JS/jquery.js" type="text/javascript"></script>
    <div id="dummy"></div>
    <script type="text/javascript">





<html><head><title>dummy.htm</title><script type=”text/javascript”></script></head><body><div><div id=”dummy”></div></div><script type=”text/javascript” src=”InternedData0”></script></body></html>



I have searched the forums and the web in general and cannot find any solution to the problem.  Other javascript that I have added works just fine – plus, I’ve checked all settings in the browser, tried switching the user-agent, cleared cache & cookies, etc.  Nothing has worked.  I added a browsers file for asp.net, but that shouldn’t matter anymore because I’m using an html file to test which is not served up by .net.   Any idea as to what the problem may be?  Thank you for any help you can provide.