Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Developer
Posts: 144
Registered: ‎06-23-2009
My Device: Not Specified

simulator can't browse to web sites

anyone know why the Blackberry 9630 sprint simulator gives me this error when I try to browse to any web site?

"Unable to connect to the selected Mobile Data Service, please try again later.  If the problem persists please contact your administrator"

 

the simulator that comes with the eclipse plugin works fine. i think thats version 4.5... any ideas would be great!

Retired
Posts: 3,708
Registered: ‎10-16-2008
My Device: Z10
My Carrier: Rogers

Re: simulator can't browse to web sites

Are you runing the MDS Simulator with your smartphone Simulator?  It acts as the communications channel for the smartphone and the Eclipse plug-in runs it for you behind the scenes.

 

Or are you trying to use this with the Eclipse plug-in.  If so, there is a minimum Simulator version requirement for compatibility for the tooling. 

Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter
Developer
Posts: 144
Registered: ‎06-23-2009
My Device: Not Specified

Re: simulator can't browse to web sites

for the 4.7 simulator i don't think i'm running the mds.  How can i run the mds for the 4.7 version?  I just downloaded the 4.7 version from the downloads page by itself. or how can i alternate between 4.5 and 4.7 with eclipse?

 

Retired
Posts: 3,708
Registered: ‎10-16-2008
My Device: Z10
My Carrier: Rogers

Re: simulator can't browse to web sites

[ Edited ]
If you have downloaded the 4.7 simulator, you can select your default simulator in your Launch Configuration for your project in Eclipse
Message Edited by tneil on 09-14-2009 03:35 PM
Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter
Developer
Posts: 144
Registered: ‎06-23-2009
My Device: Not Specified

Re: simulator can't browse to web sites

What executiable and parameters should I use?  I tried and received this error message: "unknown option: http://localhost:45614/Default.aspx try fledge /help for command line help"

 

 

 

Retired
Posts: 3,708
Registered: ‎10-16-2008
My Device: Z10
My Carrier: Rogers

Re: simulator can't browse to web sites

Are you using the Eclipse web development plug-in or the Java plugin?
Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter
Developer
Posts: 144
Registered: ‎06-23-2009
My Device: Not Specified

Re: simulator can't browse to web sites

i have the eclipse java plugin and the visual studio web plugin. and the tour simulator installed by itself.

 

Retired
Posts: 3,708
Registered: ‎10-16-2008
My Device: Z10
My Carrier: Rogers

Re: simulator can't browse to web sites

Alright.. lets see if I can bring some clarity..

 

Right now Web site debugging is not available for the BlackBerry Tour which is 4.7.1.  It is available for 4.6, 4.6.1, 4.7.0 devices.

 

If you are using any of the supported devices (check their minimum requirements on in the help and product download pages) you can use either the Eclipse Web plug-in or the Visual Studio plug-in to debug your website.  You cannot use the Java Eclipse tooling to debug your website

 

 

Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter
Developer
Posts: 144
Registered: ‎06-23-2009
My Device: Not Specified

Re: simulator can't browse to web sites

I would like to browse to the internet via the blackberry tour simulator. Sorry, maybe i should have been more clear.

 

Retired
Posts: 3,708
Registered: ‎10-16-2008
My Device: Z10
My Carrier: Rogers

Re: simulator can't browse to web sites

If you wish to simply browse to the internet using the BlackBerry tour you will first need to download and install the "BlackBerry Email and MDS Services Simulator Package" that is the first option in the list in the simulator download page found here: 

https://www.blackberry.com/Downloads/entry.do?code=060AD92489947D410D897474079C1477

 

Once you have it installed, you must run the MDS Services program first before using the BlackBerry Tour Simulator.  The MDS Services acts as a proxy for your smartphone simulator.

Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter