Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Posts: 17
Registered: ‎05-27-2011
My Device: Blackberry tablet

unable to package sencha touch 2.1 app with Ripple

[ Edited ]

Hi Guys,


Have any of you have any thoughts on the following or came a cross similar issue?


I am trying to package my sencha touch application with Ripple to BB10 device.

As far I can see everything is in the right order. I have got my config.xml in my project root. My project name is less than 10 characters. I have got all the publishing setting right in Ripple, my Ripple server is running...


However I am getting the following error during packaging 


Oh Snap! Build request failed with message: {"code":0,"data":"error"}


This is all very strange as I successfuly manage to package and debug my application om my alpha device last week. I have no idea what happend.


p.s: I 've tried toing the whole packaging manually. I've zipped up my project folder and I runned the bbwp command on it to generate my .bar. 

but again I am getting and error saying  [error] config.xml doesn't exist in the root folder

Once again doesn't make any sense as my cong.xml does exist in the root folder of my application


I've also getting the following from B&D


throw arguments[1]; // Unhandled 'error' event
Error: ENOEXEC, Not enough storage is available to process this command.
at WriteStream.write (tty_win32.js:132:5)
at Object.<anonymous> (console.js:26:18)
at Socket.<anonymous>


Which is odd as well as I have 321GB free space available.


Any thoughts would be really appriciated as I am stucked with this issue. 





Posts: 245
Registered: ‎09-21-2012
My Device: Q10
My Carrier: Virgin

Re: unable to package sencha touch 2.1 app with Ripple

Try not using a zip, and re-running your bbwp command as follows:


./bbwp <Folder_Name> <-d>


It may be that the packager cannot find the actualy config file since you zipped it into a subdirectory which happens on a MAC. Either select all the files and do "compress items" or leave as a folder.

Posts: 12
Registered: ‎11-06-2012
My Device: Alpha A
My Carrier: Wind

Re: unable to package sencha touch 2.1 app with Ripple

[ Edited ]

Has anyone found a solution for this? I am getting this exact same error about storage however I am using the new sencha 2.3 beta.






edit: I haven't solved this issue, but a work around is to use the command line way for signing your app. 



Posts: 1,382
Registered: ‎07-02-2009
My Device: BlackBerry Bold 9900
My Carrier: Bell

Re: unable to package sencha touch 2.1 app with Ripple

Also make sure that output folder is NOT within the sub-folder structure of your SOURCE. 




Source c:\code\myapp\


Output c:\temp\myapp


bbwp creates new subfolders, and you could end up in a recursive mess if it tries to zip/package the same folder that is is adding content to.  I wouldn't expect it to fill up 300GB of space quickly, but maybe your machines are limiting how much memory the process can use.



Follow me on Twitter: @n_adam_stanley
Your app doesn't work? Use BlackBerry remote web inspector to find out why.