Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Posts: 32
Registered: ‎05-05-2011
My Device: BB9700
My Carrier: mts
Accepted Solution

unknown protocol: c


I'm trying to compile a very simple Helloworld webworks application for Playbook.

I have VM player, Adobe Air SDK and JRE version is 1.6.0_03 in my machine.

But when I try to compile the code, i get the following error.


C:\Program Files\Research In Motion\BlackBerry WebWorks SDK for TabletOS\bbwp>bbwp "F:/tmp.zip" -o "F:/tmp" -d -v
[INFO]                  Parsing command line options
[INFO]                  Parsing bbwp.properties
[INFO]                  Validating WebWorks archive
[INFO]                  Parsing config.xml
[INFO]                  Validating config.xml
[INFO]                  Validating application version
[WARNING]               Failed to find a <feature> element
[INFO]                  Validating the <name> element
[INFO]                  Validating the <author> element
[WARNING]               Failed to find the <author> element
[INFO]                  Populating application source
[INFO]                  Compiling WebWorks application
Loading configuration file C:\Program Files\Research In Motion\BlackBerry WebWorks SDK for TabletOS\bbwp\blackberry-tablet-sdk\frameworks\air-config.xml
C:\Documents and Settings\uname\Local Settings\Temp\widgetGen.17313681821306493126304.tmp\tmp.swf (37380 bytes)
[INFO]                  Packaging the bar file
Error: unknown protocol: c

 Can anyone help me out on this?!


Please note:

  1. I tried searching for this issue. It is listed in "Known issues <http://docs.blackberry.com/en/developers/deliverables/21880/Known_issues_1589462_11.jsp>" and also i came accross similar issue <http://supportforums.blackberry.com/t5/Web-and-WebWorks-Development/Need-help-in-running-sample-Play...>. But the solutions given there didnt work for me.
  2. I have not used any special charecters or spaces in the command i have given.




Posts: 32
Registered: ‎05-05-2011
My Device: BB9700
My Carrier: mts

Re: unknown protocol: c

Hi All...

Hoping this reply will help someone.

I was able to solve the above mentioned probelm. Again it was "white space error". As u can see in the verbose messages, The windows "TEMP" Path has "white spaces". So changing windows temp path to "C:\TEMP" solved the problem for me.

I found the solution from <http://supportforums.blackberry.com/t5/Web-and-WebWorks-Development/Playbook-WebWork-Error-compiling...>


You can set those environment variables in "Advanced System Properties".

New Developer
Posts: 29
Registered: ‎08-21-2013
My Device: Q10
My Carrier: *

Re: unknown protocol: c

i'm bigginer 

could anyone explain how can i solve this issue step by step ?

where can i find the command line