Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Highlighted
New Developer
Posts: 12
Registered: ‎12-10-2011
My Device: Z10 LE, Playbook...
My Carrier: Telstra
Accepted Solution

unknown protocol: d ... Native Packager exception occurred

After installing new WebWorks SDK 2.0.0.54, I have an issue packaging and deploying BARs (by running either Web UI or running a "webworks run" command. Log is showing following error(s):

 

[INFO] [BUILD] Populating application source
[INFO] [BUILD] Parsing config.xml
[INFO] [BUILD] Generating output files
[INFO] [ERROR] unknown protocol: d
[INFO] [ERROR] Native Packager exception occurred
[INFO] [ERROR] unknown protocol: d
[INFO] [ERROR] Native Packager exception occurred
[INFO] An error has occurred
An error has occurred

 

If I use "old" BB Tablet OS Graphic Aid , no issues and application deployment. I tried reinstalling WebWorks (no errors reported).. I have checked all the file and folder permissions I could think of... Nothing. Seraching the forums return nothing, as well..

 

Any suggestions?

 

 

New Developer
Posts: 12
Registered: ‎12-10-2011
My Device: Z10 LE, Playbook...
My Carrier: Telstra

Re: unknown protocol: d ... Native Packager exception occurred

[ Edited ]

As soon as I posted I continued searching the forums and noticed that you can run webworks with -d switch to feed more information on the build or run commands... done that - relised that my project folder have space in the name (WebWorks Projects), so rename was invoked and now I have WebProjects folder and WebWorks is building and running apps like new!!

I hope this help someone else, as I wasted perfectly good day looking for a solution. At least I learned something,..