Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
New Member
Posts: 3
Registered: ‎03-10-2013
My Device: Simulator
My Carrier: O2

webApp with LABjs

LABjs don't work, if I load my App in the BB10 Alpha Simulator. I found not errors. I can load my webApp from a Webserver in the browser, there are not problems. Does anyone have experience with labjs, I have no idea what I can do.



I've tried option, but without success:



$LAB
.setOptions({BasePath:"local:///"})



About help I would be very happy, greetings

Bert

Highlighted
Retired
Posts: 1,382
Registered: ‎07-02-2009
My Device: BlackBerry Bold 9900
My Carrier: Bell

Re: webApp with LABjs

Sounds like a permission whitelisting error?  If LabJS is using XmlHttpRequest to load any remote resources, you need to ensure that their domains have been defined as <Access> elements in the application's config.xml file.  

 

Explained further here:

https://developer.blackberry.com/html5/documentation/access_element_834677_11.html

 

Otherwise, have you tried contacting the owners of LabJS and reporting an issue?

Follow me on Twitter: @n_adam_stanley
-------------------------------------------------------------------------------------------------------------------------
Your app doesn't work? Use BlackBerry remote web inspector to find out why.