Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Thank you for visiting the BlackBerry Support Community Forums.

BlackBerry will be closing the BlackBerry Support Community Forums Device Forums on April 1st (Developers, see below)

BlackBerry remains committed to providing excellent customer support to our customers. We are delighted to direct you to the CrackBerry Forums, a well-established and thorough support channel, for continued BlackBerry support. Please visit http://forums.crackberry.com or http://crackberry.com/ask. You can also continue to visit BlackBerry Support or the BlackBerry Knowledge Base for official support options available for your BlackBerry Smartphone.

"When we launched CrackBerry.com 10 years ago, we set out to make it a fun and useful destination where BlackBerry Smartphone owners could share their excitement and learn to unleash the full potential of their BlackBerry. A decade later, the CrackBerry community is as active and passionate as ever and I know our knowledgeable members and volunteers will be excited to welcome and assist more BlackBerry owners with their questions."

- Kevin Michaluk, Founder, CrackBerry.com

Developers, for more information about the BlackBerry Developer Community please review Join the Conversation on the BlackBerry Developer Community Forums found on Inside BlackBerry.

New Developer
Posts: 26
Registered: ‎04-25-2010
My Device: none
My Carrier: none

Re: webworks compile sketchPad example - stuck!

Here is how the compile could start to be developed as an automator workflow:


Open Automator (in Applications folder)

File -> New

Choose "Service"


Top pop up menu -> Service Receives Selected Folders -> in any Application

From actions on left column: Utilities -> "Run Shell Script"

On top right of the shell script action (pop up menu) -> Pass Input -> as arguments


now the tricky bit.. I used this as the bash script - depends on path to the bbwp program



cd "$@"
zip output *
/Users/blackberrydev/bbwp/bbwp output.zip


Save the new automator service. Now run it as follows:

select the folder with your HTML, config.xml etc.

go to Finder Menu -> Services -> {name of action as saved}


(or more simply right click on the folder and there should be the action in the context menu)


it takes a few seconds before the compiled output.bar file appears inside the folder in a "bin" folder






New Contributor
Posts: 2
Registered: ‎02-24-2011
My Device: Playbook

Re: webworks compile sketchPad example - stuck!

Oh Horray, I'd been stuck on this for an hour Smiley Happy When I uncompressed it it created a folder, so my assumption was that I should simply recompress that folder to make an archive.


Thanks so much Rizer.

Regular Contributor
Posts: 50
Registered: ‎02-14-2011
My Device: Not Specified

Re: webworks compile sketchPad example - stuck!(Re: DS_Store issue)

[ Edited ]

Hi Rizer,

     I tried doing this a few different ways but it's not working for me. If possible, would you write up some step-by-step instructions?


I've tried dragging into the Terminal: the project directory, the build directory & the .zip file. For the first two when I run the command you suggested, I just get a 'this is a directory' message. for the .zip file i get 'permission denied'.

Posts: 1
Registered: ‎10-26-2011
My Device: Playbook
My Carrier: WIFI

Re: webworks compile sketchPad example - stuck! (Re: DS_Store issue)

Also had these problems. the example downloaded from the developer site contanis additional files and does require to zip a folder.


First always got an error about not being able to complie hidden files. Solve dthis by downloading the free yemuzip

http://www.yellowmug.com/yemuzip/ which allows you to zip files excluding hidden mac files.


But now got an error that the config.xml could not be found. I draged the folder onto the zip program to compress it, which does not work.


You have to open the folder and drag its content (select all files) onto the zip program.

The then named archive can be complied without errors. 

Posts: 28
Registered: ‎02-11-2011
My Device: Not Specified

webworks compile sketchPad example - simulation stuck


The sketchpad example doesn't draw in the bb10 simulator but works fine in ripple.

Anyone know the updates to get it to work in the simulator?