Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Posts: 23
Registered: ‎04-01-2011
My Device: Curve 8520
My Carrier: Vodacom SA



I want to be able to insert a message into the users message list.

I did some research about this and found a solution that uses webworks.message.list

But now when I run my app on a blackberry device it gives the following message:

error starting "appname" class 'webworks.message.model.custommessage' multiply defined.

Please help with this.

Thanks in advance
Posts: 15
Registered: ‎04-05-2011
My Device: Torch
My Carrier: development

Re: webworks.message.list

 The folder structure was the problem. I had an 
C:\Program Files\Research In Motion\BlackBerry WebWorks Packager\ext\webworks.message.list\webworks

Just renamed it to "src" and it seems to work. 

For me it was not clear from the instructions hot to use the extenxtions. 
Copy the downloaded Smartphone\MessageList\src\webworks directory to your new ext\webworks.message.list\webworks directory

Posts: 17
Registered: ‎08-19-2011
My Device: none
My Carrier: none

Re: webworks.message.list

I just hit this issue also when developing several webworks applications. (WebWorks SDK


I created the first application and used the extension for the message list at https://github.com/blackberry/WebWorks-Community-APIs/tree/master/Smartphone/MessageList ,  and everything worked fine.


Then I developed another application that used the same extension. When launching the second application I receive CustomMessage "multiply defined"  error.  So I did some testing and research and found that Persistable is likely the cause and found that CustomMessage implements Persistable.   


I read several post about not using Persistable in libraries,  and one reference saying it is OK when used in extensions.  I tried refractoing CustomMessage  so that is has a unique name,  but then end up with a similar error:  ReadableListImpl multiply defined.  


Anyone come across this and resolve it?