Appropriate version of the BlackBerry Native SDK

by BlackBerry Development Advisor on ‎04-04-2013 02:16 PM (6,844 Views)

When creating and building your application, it is important to choose the correct version of the BlackBerry® Native® SDK to make sure that the application is compatible with the target BlackBerry operating system versions. Applications built in the BlackBerry Native SDK are forward-compatible with later BlackBerry® OS versions, but they are not backward-compatible with ealier versions.

 

For example, an application built using BlackBerry Native SDK 10.1 can run on BlackBerry devices running BlackBerry OS 10.1 and later will not run on a BlackBerry device running BlackBerry OS 10.0.9. Thus, when building applications, you should use a BlackBerry Native SDK version that matches the lowest version of BlackBerry OS you want to support.

 

It is also recommended to use gold versions of the BlackBerry Native SDK to build the final release version of your application.  Applications built using beta versions of the BlackBerry Native SDK should not be uploaded to BlackBerry® World™.